ActiveMQ
  1. ActiveMQ
  2. AMQ-1142

TemporaryQueue communication not working

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.0
    • Fix Version/s: 5.0.0
    • Component/s: Broker, JMS client
    • Labels:
      None
    • Environment:

      WinXP, Java 1.4.2

      Description

      Assume a (old legacy, yes this is out of date and better solutions are available) point to point architecture:

      Client creates temporary queues and send the queuename to the server by a fixed queue ('command queue')
      Server uses the received queue names to send messages to the client.

      See the attached Code snippets:

      • Start the Server
      • Start the Client
      • The Client creates a temporary queue and sends the name to the server
      • Server receives message and sends a test message back.
      • Client NEVER receives the test message

      This works 100% on IBM MQSeries (the only source diff is the line that has a MQSerie getQueue API call, instead a createQueue, because queus are defined, and not dynamical as in ActiveMQ)

      ActiveMQ LOG information:

      The temporary queue is logged, but later it says that there are no subscriptions

      (..)
      DEBUG AbstractRegion - Adding destination: topic://ActiveMQ.Advisory.Consumer.Queue.ID:TIGER-2615-1170064714906-1:0:1
      DEBUG JournalPersistenceAdapter - Checkpoint done.
      DEBUG TIGER-2615-1170064714906-1:0:1 - No subscriptions registered, will not dispatch message at this time.
      (...)

      Can this bug be fixed?

      Thank you, Jos

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Jos
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development