Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-25497

problems with AMBARI Installation Guide

    XMLWordPrintableJSON

    Details

    • Type: Documentation
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      https://cwiki.apache.org/confluence/display/AMBARI/Installation+Guide+for+Ambari+2.7.5

       

      1. RAT is complaing too many unapproved licenses

      Which can be solved by

       

      changing 

       

      mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972 -DskipTests -Dpython.ver="python >= 2.6"

       

      to

       

      mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972 -DskipTests -Dpython.ver="python >= 2.6" -Drat.skip=true

       

      2. node version is too old that it causes ambari-admin failed to build.

       

      Should add a step to update ambari-admin/pom.xml with changes like

       

      <nodeVersion>v10.19.0</nodeVersion>
      {{ <npmVersion>6.13.4</npmVersion>}}

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              wangxiaohu Tiger Wang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: