Uploaded image for project: 'Ambari (Retired)'
  1. Ambari (Retired)
  2. AMBARI-25270

Admin View build fails due to unavailable npm package "ecstatic"

    XMLWordPrintableJSON

Details

    Description

      ambari-admin build started failing with:

      [ERROR] npm ERR! notarget No compatible version found: ecstatic@'>=0.4.0 <0.5.0'
      [ERROR] npm ERR! notarget Valid install targets:
      [ERROR] npm ERR! notarget ["4.1.2"]
      ...
      [ERROR] npm ERR! notarget It was specified as a dependency of 'http-server'
      

      It seems old versions of ecstatic have been removed due to a security issue.

      Attachments

        Issue Links

          Activity

            People

              adoroszlai Attila Doroszlai
              adoroszlai Attila Doroszlai
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h