Uploaded image for project: 'Ambari (Retired)'
  1. Ambari (Retired)
  2. AMBARI-24584

KAFA-INSTALL install kafka service failed with ERROR: set command takes 2 parameters, instead of 1

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 2.4.2
    • None
    • ambari-admin
    • None
    • Important

    Description

      1.Install Ambari 

      2.install hadoop cluster

      3.add service kafka

      4.select multiple kafka broker 

      5.begin install kafka service 

      6.observe result

       

      actual result:

           install failed with error:     
      resource_management.core.exceptions.ExecutionFailed: Execution of 'ambari-sudo.sh /usr/bin/hdp-select set all `ambari-python-wrap /usr/bin/hdp-select versions | grep ^2.5.3.0-37 | tail -1`' returned 1. ERROR: set command takes 2 parameters, instead of 1

      error.txt

      expected result:

          install kafka service successfully

      Attachments

        1. error.txt
          3 kB
          kai zhao
        2. stdoout.txt
          8 kB
          kai zhao

        Activity

          People

            Unassigned Unassigned
            WanderingEachDay kai zhao
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: