Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-20726

Aggregate alert does not show status properly at Maintenance Mode change

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.2
    • Fix Version/s: trunk
    • Component/s: alerts
    • Labels:
      None

      Description

      Aggregate alert does not show status properly at Maintenance Mode change.

      Steps to reproduce:
      Install a cluster that has HBase with one regionserver installed.

      Scenario 1:
      1. Turn On Maintenance Mode on the RegionServer or on the RegionServer host or on the HBase service.
      2. Stop the RegionServer after that.
      3. No red alerts will show as expected.
      Percent RegionServers Available - OK affected: [0], total: [1]
      4. Now Turn Off Maintenance Mode, still keep the RegionServer down.
      But Percent RegionServers Available alert will still show "OK" - "CRIT" is expected.

      Scenario 2:
      1) Stop the RegionServer - Red alert will show as expected.
      Percent RegionServers Available - CRIT affected: [1], total: [1]
      2) Now Turn On Maintenance Mode - For RegionServer status, Red alert will be gone as expected.
      But Percent RegionServers Available alert will still show "CRIT" - "OK" is expected.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                qinliu Qin Liu
                Reporter:
                qinliu Qin Liu
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: