Ambari
  1. Ambari
  2. AMBARI-1605

Host registration fail due to unsupported OS should provide better message

    Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 1.2.1
    • Fix Version/s: None
    • Component/s: agent
    • Labels:
      None

      Description

      When trying to install AMbari Agent on a machine w/ an unsupported OS, you get a cryptic message. Should be more user friendly, informing the user that registration failed due to unsupported OS.

      http://hortonworks.com/community/forums/topic/error-while-installing-hosts/

      File “/usr/lib64/python2.6/socket.py”, line 567, in create_connection
      raise error, msg
      error: [Errno 111] Connection refused

      [....]

      INFO 2013-03-08 08:42:45,442 security.py:49 – SSL Connect being called.. connecting to the server
      INFO 2013-03-08 08:42:45,444 Controller.py:103 – Unable to connect to: https://ambari:8441/agent/v1/register/slave
      Traceback (most recent call last):
      File “/usr/lib/python2.6/site-packages/ambari_agent/Controller.py”, line 88, in registerWithServer
      response = self.sendRequest(self.registerUrl, data)
      File “/usr/lib/python2.6/site-packages/ambari_agent/Controller.py”, line 239, in sendRequest

        Activity

        Jeff Sposetti created issue -
        Jeff Sposetti made changes -
        Field Original Value New Value
        Issue Type Bug [ 1 ] Improvement [ 4 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Jeff Sposetti
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:

              Development