Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-14343

HiveServer Upgrade Fails Because Of Missing Kerberos Properties

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: ambari-server
    • Labels:
      None

      Description

      When upgrading Hive from HDP 2.1 to HDP 2.3, Hive server will not start correctly if it has been Kerberized. This is because new properties introduced in HDP 2.2 and 2.3 are not being calculated and set on hive-site.

      • If not kerberized, then we do nothing
      • If Kerberized
        "hive.cluster.delegation.token.store.class": "org.apache.hadoop.hive.thrift.ZooKeeperTokenStore",
        "hive.zookeeper.quorum": "server1:2182,server2:2181,server2:2181"
        "hive.cluster.delegation.token.store.zookeeper.connectString": "server1:2182,server2:2181,server2:2181"
        

        Attachments

        1. AMBARI-14343.patch
          22 kB
          Jonathan Hurley

          Issue Links

            Activity

              People

              • Assignee:
                jonathan.hurley Jonathan Hurley
                Reporter:
                jonathan.hurley Jonathan Hurley
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: