Ambari
  1. Ambari
  2. AMBARI-1428

Instructions for manual install of Ambari Agents have wrong information for the /etc/ambari-agent/conf/ambari-agent.ini file.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: None
    • Component/s: documentation
    • Labels:
      None
    • Environment:

      RHEL6.2 on VM. Installing Ambari 1.2.0.

      Description

      The example is at: http://incubator.apache.org/ambari/1.2.1/installing-hadoop-using-ambari/content/ambari-chap6-1.html

      In step 2, the example for /etc/ambari-agent/conf/ambari-agent.ini shows:

      [server]
      hostname=

      {your.ambari.server.hostname}

      url_port=4080
      secured_url_port=8443

      The url_port and secured_url_port values do not match defaults:

      url_port=8440
      secured_url_port=8441

      Changing the /etc/ambari-agent/conf/ambari-agent.ini to the example values causes the Confirm Hosts step in the Cluster Install Wizard to fail.

        Activity

        Hide
        Ellen Evans added a comment -

        I just want to clarify - you seem to be installing the 1.20 bits with the 1.2.1 instructions. Is that correct?

        Show
        Ellen Evans added a comment - I just want to clarify - you seem to be installing the 1.20 bits with the 1.2.1 instructions. Is that correct?
        Hide
        Gunnar Tapper added a comment -

        The 1.2.0 instructions are exactly the same for this part.

        Show
        Gunnar Tapper added a comment - The 1.2.0 instructions are exactly the same for this part.
        Hide
        Gunnar Tapper added a comment -

        Refer to: http://incubator.apache.org/ambari/1.2.0/installing-hadoop-using-ambari/content/ambari-chap6-1.html (the link to the 1.2.0 document was replaced with the 1.2.1 version for some reason):

        vi /etc/ambari-agent/conf/ambari-agent.ini

        [server]
        hostname=

        {your.ambari.server.hostname}

        url_port=4080
        secured_url_port=8443

        Show
        Gunnar Tapper added a comment - Refer to: http://incubator.apache.org/ambari/1.2.0/installing-hadoop-using-ambari/content/ambari-chap6-1.html (the link to the 1.2.0 document was replaced with the 1.2.1 version for some reason): vi /etc/ambari-agent/conf/ambari-agent.ini [server] hostname= {your.ambari.server.hostname} url_port=4080 secured_url_port=8443
        Hide
        Ellen Evans added a comment -

        Agreed. I just wanted to eliminate any possible external issues. We need to work through a way of updating the docs, and then this will be fixed.

        Show
        Ellen Evans added a comment - Agreed. I just wanted to eliminate any possible external issues. We need to work through a way of updating the docs, and then this will be fixed.
        Hide
        Ellen Evans added a comment -

        Added Yusaku re: the update issue.

        Show
        Ellen Evans added a comment - Added Yusaku re: the update issue.
        Hide
        Ellen Evans added a comment -

        Should get to this in the next two weeks.

        Show
        Ellen Evans added a comment - Should get to this in the next two weeks.
        Hide
        Ellen Evans added a comment -

        Patch in AMBARI-1556

        Show
        Ellen Evans added a comment - Patch in AMBARI-1556
        Hide
        Ellen Evans added a comment -

        Work now covered by Ambari-1556 (https://issues.apache.org/jira/browse/AMBARI-1556). Closing this.

        Show
        Ellen Evans added a comment - Work now covered by Ambari-1556 ( https://issues.apache.org/jira/browse/AMBARI-1556 ). Closing this.

          People

          • Assignee:
            Ellen Evans
            Reporter:
            Gunnar Tapper
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development