Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-12696

Server error was present when would have tried to add host (after upgrade secured cluster from 2.0.0 /1.7.0 to 2.1.1)

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.1.1
    • Component/s: ambari-server
    • Labels:
      None

      Description

      STR 1 (2.0.0):
      1)Deploy old version
      2)Enable security
      2)Make ambari only upgrade
      3)Stop all services
      4)Try to add Host with clients only
      STR 2 (1.7.0):
      1)Deploy old version
      2)Make ambari only upgrade
      3)Enable security
      4)Try to add Host with clients only
      Actual results
      Server error was present when would have tried to add host at Review page, after clicking 'deploy'
      After error was presented, I clicked 'Ok' and closed wizard. I navigated at the added host:
      1)Components were in padding state. It is correct behavior
      2)Server error was present (500 error code). It is incorrect behavior

        Attachments

        1. AMBARI-12696.patch
          2 kB
          Dmytro Sen

          Issue Links

            Activity

              People

              • Assignee:
                dsen Dmytro Sen
                Reporter:
                dsen Dmytro Sen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: