Ambari
  1. Ambari
  2. AMBARI-1235

Host health indicator should have a tooltip showing details

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1
    • Component/s: client
    • Labels:
      None
    1. AMBARI-1235.patch
      6 kB
      Yusaku Sako
    2. AMBARI-1235-part2.patch
      4 kB
      Yusaku Sako

      Activity

      Srimanth Gunturi added a comment -

      On a host, I stopped all its host-components ( ZooKeeper Server / ZooKeeper, Ganglia Monitor / Ganglia, TaskTracker / MapReduce, HBase RegionServer / HBase, DataNode / HDFS), and it showed the host as red-circle. When I hovered on it, only 'ZOOKEEPER_SERVER is down' was shown. Was hoping to see other details too if any.

      Yusaku Sako added a comment -

      @Srimanth, that is the intended behavior.
      The hover tooltip would show what's causing the host health status to be the current color.
      When red, hover should show which masters are down (in this case, ZooKeeper Server).
      Once the ZooKeeper is up, the indicator should turn orange, and show which slave components are down (in this case, Ganglia Monitor, TaskTracker, HBase Region Server, and DataNode).
      I think to make this clear, we should modify the tooltip content a bit:

      Tooltip on red:

      • The following master components are down:<br> {comma-delim list of master components not in STARTED state}

      Tooltip on orange:

      • The following slave components are down:<br>{{comma-delim list of slave components not in STARTED state}

      Tooltip on yellow:

      • The server has not received a heartbeat from this host for more than 3 minutes.
      Yusaku Sako added a comment -

      Posted a patch for implementing the changes described in the comment above.

      Yusaku Sako added a comment -

      Committed to trunk.


        People

        • Assignee:
          Yusaku Sako
          Reporter:
          Yusaku Sako
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development