Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-12318

Phoenix rolling upgrade should use hbase specific configs

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: stacks
    • Labels:
      None

      Description

      conf-select set-conf-dir failed during RU because there are no /usr/hdp/2.3.0.0-2529/phoenix/conf and looks like conf-select create was never executed for a Phoenix component.

      resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package phoenix --stack-version 2.3.0.0-2529 --conf-version 0' returned 1. /usr/hdp/2.3.0.0-2529/phoenix/conf does not exist
      

      Phoenix package is distributed without conf folder, so during initial install conf-select create was skipped.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sumitmohanty Sumit Mohanty
                Reporter:
                sumitmohanty Sumit Mohanty
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: