Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-10119

Rolling Upgrade "Upgrade" Action Actually Starts "Install Versions"

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: ambari-web
    • Labels:
      None

      Description

      I created a clean cluster with all services and enabled NameNode HA in preparation for an upgrade. I distributed my new HDP version to all 20 hosts, but some hosts failed because of repository issues.

      I went to each failed host and manually retried the installation, which seems to work. When I went to Manage Versions, it showed my new stack with only 18 out of 20 hosts upgraded. I had to wait about 10 seconds for it to show me all 20 hosts had the correct stack version.

      At this time, the "Install" button changed to "Upgrade". I hit Upgrade, but the second I hit it all 20 hosts went down to 0 for "Installed" and instead of an upgrade, Ambari tried to re-install the stack on all hosts that already had it.

      The installation went very quickly since all hosts already had the bits.

      I noticed that, in general, the Stacks and Versions section was slow to update, sometimes showing me information from several minutes ago. For example, I had 14 hosts installed, but it only said 4 were. As I waited, it eventually caught up.

        Attachments

        1. AMBARI-10119.patch
          4 kB
          Andriy Babiichuk

          Activity

            People

            • Assignee:
              ababiichuk Andriy Babiichuk
              Reporter:
              ababiichuk Andriy Babiichuk
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: