Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-7035

Increment the pip version in Airflow Dockerfile

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 1.10.9
    • Fix Version/s: None
    • Component/s: ci
    • Labels:
      None

      Description

      The current pip version in (https://github.com/apache/airflow/blob/master/Dockerfile#L298) does not support some  APIs in Airflow.

      Eg: tableauhyperapi gets the following error while being installed in GCP Composer environemnt.

      ```

      No matching distribution found for tableauhyperapi (from -r requirements.txt (line 3))"

      ```

      This same error gets resolved when we locally upgrade pip to 20.0.2 .

      Will it be possible to do the upgrade in the Airflow Docker File, so that Airflow can also support this (and other) APIs? 

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Gogoi Aditya
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: