Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-5657

Upgrade dill dependency

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.10.5
    • Fix Version/s: 1.10.6
    • Component/s: dependencies
    • Labels:
      None

      Description

      Airflow depends on "dill>=0.2.2, <0.3'," (https://github.com/apache/airflow/blob/1a4c16432b8718189269e63c3afcd2709eed7379/setup.py#L359).

      However there is a new 0.3.x range for dill (https://pypi.org/project/dill/)

      I would like to upgrade the version to the same range that matches Apache Beam's version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                altay Ahmet Altay
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: