Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-5561

Very old version of httplib2 installed when using gcp extra

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.10.3, 1.10.4, 1.10.5
    • Fix Version/s: 1.10.6
    • Component/s: gcp
    • Labels:
      None

      Description

      After starting to use poetry to properly resolve airflow dependencies I faced network issues that I pinpointed to httplib2 interactions with proxy in my corporate network.

      When making an http request I would get a "Network not reachable" exception

      I isolated the problem to happen when using a very old version of httplib2 while using gcp extra which has a dependency range too strict (~=0.9.2)

      I noticed that this dependency used to be httplib2>=0.9.2 and it was changed as part of AIRFLOW-3971  commit (91b856f) without a clear reason why a more strict dependency is needed

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kamil.bregula Kamil Bregula
                Reporter:
                camilomartinez Camilo Martinez
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: