Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-5054

Upgrading to 1.10.3 from 1.10

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.10.1
    • Fix Version/s: 1.10.0
    • Component/s: celery
    • Labels:
      None

      Description

      I am trying to upgrade my version to 1.10.3 but celery cannot find my result_backend option in my config after version 1.10.0  Version 1.10.0 is working for me. 

       

      I have renamed it to the result_backend in the airflow.cfg.  However, I am still getting the warning (see below) to rename it.  I also believe this is causing the dag not run and returning the following error message: airflow.exceptions.AirflowException: dag_id could not be found: {dag_id}. Either the dag did not exist or it failed to parse.

       

      /usr/local/lib/python3.6/site-packages/airflow/config_templates/default_celery.py:51: DeprecationWarning: The celery_result_backend option in [celery] has been renamed to result_backend - the old setting has been used, but please update your config.
      'result_backend': configuration.conf.get('celery', 'RESULT_BACKEND'),

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              crhyatt Christopher Hyatt
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: