Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-4902

Flask 1.1.0 release breaks airflow 1.10.3

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.10.3
    • Fix Version/s: None
    • Component/s: cli
    • Labels:
      None

      Description

      When setting up an environment by installing airflow 1.10.3, the new version of flask breaks airflow:

       

      Command ran:

       

      pip install apache-airflow[crypto,kubernetes,postgres,hive,jdbc,ssh,s3]==1.10.3 
      

       

      Installation output:

       

      ERROR: apache-airflow 1.10.3 has requirement jinja2<=2.10.0,>=2.7.3, but you'll have jinja2 2.10.1 which is incompatible.
      ERROR: apache-airflow 1.10.3 has requirement werkzeug<0.15.0,>=0.14.1, but you'll have werkzeug 0.15.4 which is incompatible.
      

       

      Command ran:

       

      airflow initdb
      

       

      Output:

       

      Traceback (most recent call last):
      File "/.Envs/airflow3/bin/airflow", line 21, in <module>
      from airflow import configuration
      File "/.Envs/airflow3/lib/python3.6/site-packages/airflow/_init_.py", line 40, in <module>
      from flask_admin import BaseView
      File "/.Envs/airflow3/lib/python3.6/site-packages/flask_admin/_init_.py", line 6, in <module>
      from .base import expose, expose_plugview, Admin, BaseView, AdminIndexView # noqa: F401
      File "/.Envs/airflow3/lib/python3.6/site-packages/flask_admin/base.py", line 6, in <module>
      from flask import Blueprint, current_app, render_template, abort, g, url_for
      File ".Envs/airflow3/lib/python3.6/site-packages/flask/_init_.py", line 20, in <module>
      from .app import Flask
      File ".Envs/airflow3/lib/python3.6/site-packages/flask/app.py", line 69, in <module>
      from .wrappers import Request
      File ".Envs/airflow3/lib/python3.6/site-packages/flask/wrappers.py", line 14, in <module>
      from werkzeug.wrappers.json import JSONMixin as _JSONMixin
       ModuleNotFoundError: No module named 'werkzeug.wrappers.json'; 'werkzeug.wrappers' is not a package
       
      

       

      After forcing flask to 1.0.4 the command "airflow initdb" works. I believe removing the restriction of werkzeug version might solve this problem, since the error at installation seems to point to that

       

      NOTE: not sure which priority to assign to this, added major since it breaks without explicitly adding the flask version

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                catarinasilva Catarina Silva
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: