Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-4900

Incompatible version of Werkzeug after Flask upgrade

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.10.3
    • Fix Version/s: 1.10.4
    • Component/s: webserver
    • Labels:
      None

      Description

      On July 5th morning UTC+7, Flask have released version 1.1.0, which will be used in airflow because we have requirements for flask as follows: 'flask>=1.0, <2.0'

      However, flask pinned their Werkzeug to "Werkzeug>=0.15" which is incompatible with airflow's Werkzeug ('werkzeug>=0.14.1, <0.15.0'), resulting to error when doing "from airflow import model":

      ERROR: Failure: ImportError (No module named 'werkzeug.wrappers.json'; 'werkzeug.wrappers' is not a package)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                umanium Luqman Abdul Mushawwir
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: