Uploaded image for project: 'Apache Airflow'
  1. Apache Airflow
  2. AIRFLOW-1430

GPL licensing issues

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Fixed
    • 1.8.1, 1.8.2, 1.9.0
    • 1.10.0
    • None
    • None

    Description

      The current requirements require the install of the GPLv2 licensed package Unidecode .

      This is a violation to the ASF licensing conditions, c.f.

      https://www.apache.org/legal/resolved.html#category-x
      https://www.apache.org/legal/resolved.html#prohibited

      The requirement comes in via:
      python-nvd3 https://github.com/areski/python-nvd3
      -> python-sluggify https://github.com/un33k/python-slugify
      -> Unidecode https://github.com/avian2/unidecode

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              fjetter Florian Jetter
              Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: