Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.8.0
    • Fix Version/s: None
    • Component/s: hooks
    • Labels:
      None

      Description

      The BigQueryHook class is using pandas.io.gbq GbqConnector class but it has been deprecated from pandas v0.20.1. On installation airflow required pandas version between 0.17 and 1.0.

      Because of that there is an error on DAG loading:

        File "/usr/local/lib/python2.7/site-packages/airflow/models.py", line 263, in process_file
          m = imp.load_source(mod_name, filepath)
        File "/Users/dboyadzhiev/airflow/dags/ETL/HRSkyen/transformer.py", line 8, in <module>
          from airflow.contrib.operators.bigquery_operator import BigQueryOperator
        File "/usr/local/lib/python2.7/site-packages/airflow/contrib/operators/bigquery_operator.py", line 17, in <module>
          from airflow.contrib.hooks.bigquery_hook import BigQueryHook
        File "/usr/local/lib/python2.7/site-packages/airflow/contrib/hooks/bigquery_hook.py", line 27, in <module>
          from pandas.io.gbq import GbqConnector, \
      ImportError: cannot import name GbqConnector
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dboyadzhiev Dimo Boyadzhiev
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: