Airavata
  1. Airavata
  2. AIRAVATA-49

MinID values are not setting properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0
    • Component/s: WS-Messenger
    • Labels:
      None
    • Environment:
      mac

      Description

      This is an intermittent issue, please follow these steps to reproduce the issue.

      1. Configure ws-messenger to run in persistent mode with turned off delivery mode.
      2. Run the wse-multiple-producer-consumer sample.
      3. Stop the broker and Ideally there should be messages in disQ table. (don't stop the client program).
      4. Set the delivery to true and start the broker again.
      5. Messages are not delivered to the consumer Service started in step 2.
      6. If encounter this issue set the minIDTable value to the minimum ID in disQ and restart the broker.. you will see the delivery of messages in consumerService.

      Note: Ideally broker should pick the messages from disQ table and deliver them to the consumer service, but sometimes the minIDTable values is less than the value in disQ minimum ID so it doesn't deliver any messages. I think we should fix this issue by incrementing the minIDTable value or makesure it is always the minimum value of disQ table.

      Regards
      Lahiru

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1351d 23h 21m 1 Suresh Marru 09/Apr/15 21:10
        Suresh Marru made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Suresh Marru added a comment -

        This is no longer relevant since WS messenger is deprecated and repalced by rabbitmq.

        Amila Jayasekara made changes -
        Fix Version/s 1.0 [ 12323361 ]
        Fix Version/s 0.9 [ 12323884 ]
        Suresh Marru made changes -
        Fix Version/s 0.9 [ 12323884 ]
        Fix Version/s 0.8 [ 12323883 ]
        Suresh Marru added a comment -

        This issues seem to be lingering since 0.2. Deferring to 0.9 for now, but need to reproduce it in 0.8 release and fix if the issue persists.

        Lahiru Gunathilake made changes -
        Fix Version/s 0.8 [ 12323883 ]
        Fix Version/s 0.7 [ 12323148 ]
        Saminda Wijeratne made changes -
        Fix Version/s 0.7 [ 12323148 ]
        Fix Version/s 0.6 [ 12322484 ]
        Lahiru Gunathilake made changes -
        Fix Version/s 0.6 [ 12322484 ]
        Fix Version/s 0.5 [ 12318558 ]
        Lahiru Gunathilake added a comment -

        moving to next release.

        Lahiru Gunathilake made changes -
        Fix Version/s 0.5-INCUBATING [ 12318558 ]
        Fix Version/s 0.4-INCUBATING [ 12318557 ]
        Lahiru Gunathilake added a comment -

        Since this issue is not critical and hard to reproduce we are moving this to next release.

        Regards
        Lahiru

        Lahiru Gunathilake made changes -
        Fix Version/s 0.4-INCUBATING [ 12318557 ]
        Fix Version/s 0.3-INCUBATING [ 12318556 ]
        Chathura Herath made changes -
        Fix Version/s 0.2-INCUBATING [ 12318555 ]
        Chathura Herath made changes -
        Fix Version/s 0.3-INCUBATING [ 12318556 ]
        Suresh Marru made changes -
        Fix Version/s 0.2-INCUBATING [ 12318555 ]
        Fix Version/s 0.1-INCUBATING [ 12318554 ]
        Suresh Marru added a comment -

        Defering this issue to 0.2 version, as this is a non-trivial to reproduce. There are changes since this is first reported, need to dig deeper on this issue for 0.2 release.

        Suresh Marru made changes -
        Field Original Value New Value
        Fix Version/s 0.1-INCUBATING [ 12318554 ]
        Lahiru Gunathilake created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Lahiru Gunathilake
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development