Airavata
  1. Airavata
  2. AIRAVATA-333

exception when running workflow through AiravataClient

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 0.3-INCUBATING
    • Fix Version/s: None
    • Component/s: Registry API
    • Labels:
      None
    • Environment:
      linux, jdk1.6, SimpleMath workflow

      Description

      workflow runs and returns result correctly, but airavata server shows a series of exceptions:

      203581 [Client Event Poller] ERROR org.apache.jackrabbit.rmi.observation.ClientEventPoll - Unexpected failure of Listener org.apache.airavata.common.registry.api.impl.JCRRegistry$1@442c76
      java.util.ConcurrentModificationException
      at java.util.HashMap$HashIterator.nextEntry(HashMap.java:793)
      at java.util.HashMap$KeyIterator.next(HashMap.java:828)
      at org.apache.airavata.common.registry.api.impl.JCRRegistry$1.onEvent(JCRRegistry.java:108)
      at org.apache.jackrabbit.rmi.observation.ClientEventPoll.run(ClientEventPoll.java:224)

        Activity

        Xuan Wu added a comment -

        Not sure if related, but such exception as below also shows sometimes:

        org.apache.airavata.xbaya.XBayaException: org.apache.airavata.common.registry.api.exception.RegistryException: Error while saving workflow execution service data!!!
        at org.apache.airavata.xbaya.provenance.ProvenanceWrite.saveNodeOutputs(ProvenanceWrite.java:211)
        at org.apache.airavata.xbaya.provenance.ProvenanceWrite.run(ProvenanceWrite.java:75)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
        Caused by: org.apache.airavata.common.registry.api.exception.RegistryException: Error while saving workflow execution service data!!!
        at org.apache.airavata.registry.api.impl.AiravataJCRRegistry.saveWorkflowIO(AiravataJCRRegistry.java:814)
        at org.apache.airavata.registry.api.impl.AiravataJCRRegistry.saveWorkflowExecutionServiceOutput(AiravataJCRRegistry.java:798)
        at org.apache.airavata.xbaya.provenance.ProvenanceWrite.saveNodeOutputs(ProvenanceWrite.java:209)
        ... 4 more
        Caused by: java.lang.NullPointerException
        at org.apache.airavata.common.registry.api.impl.JCRRegistry.getOrAddNode(JCRRegistry.java:308)
        at org.apache.airavata.registry.api.impl.AiravataJCRRegistry.getWorkflowDataNode(AiravataJCRRegistry.java:947)
        at org.apache.airavata.registry.api.impl.AiravataJCRRegistry.getWorkflowExperimentDataNode(AiravataJCRRegistry.java:941)
        at org.apache.airavata.registry.api.impl.AiravataJCRRegistry.saveWorkflowIO(AiravataJCRRegistry.java:807)
        ... 6 more

        Sachith Withana added a comment -

        First issue won't be fixed since Jackrabbit is not being used now.
        But would you please let me know how to recreate the next issue? When it was thrown?

        Saminda Wijeratne added a comment -

        Looking at the 2nd exception in the comment by Xuan Wu I'd say this issue is obsolete. We did not see a similar issue with the JPA implementation for the past 1.5 years, so I'd vote to resolve this issue.

        Chathuri Wimalasena added a comment -

        Airavata client is now thrift based. This issue is no longer valid.


          People

          • Assignee:
            Unassigned
            Reporter:
            Xuan Wu
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development