David Medinets noticed
A Property object used to hold key-value information used to modify
the behavior of an Interator. However, these are the methods
Is there a reason why the same concept as two names? I'd like to
settle on one name and standardise.
Could we change the names to be something like
getInteratorSettingProperties? I know that some people are annoyed by
longer method names, but when searching through a code base, have
unique names is handy. Searching for a generically named method - such
as getProperties, returns a lot of false positives.