Accumulo
  1. Accumulo
  2. ACCUMULO-380

UnsupportedOperation exception on wikisearch example

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Running a query on the wikisearch example results in this exception in the tablet server logs:

      009 20:36:17,364 [thrift.TabletClientService$Processor] ERROR: Internal error processing startMultiScan
      java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
              at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1321)
              at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.startMultiScan(TabletServer.java:1272)
              at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at cloudtrace.instrument.thrift.TraceWrap$1.invoke(TraceWrap.java:58)
              at $Proxy2.startMultiScan(Unknown Source)
              at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor$startMultiScan.process(TabletClientService.java:2164)
              at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor.process(TabletClientService.java:2037)
              at org.apache.accumulo.server.util.TServerUtils$TimedProcessor.process(TServerUtils.java:151)
              at org.apache.thrift.server.TNonblockingServer$FrameBuffer.invoke(TNonblockingServer.java:631)
              at org.apache.accumulo.server.util.TServerUtils$THsHaServer$Invocation.run(TServerUtils.java:199)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
              at java.lang.Thread.run(Thread.java:662)
      Caused by: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
              at org.apache.accumulo.server.tabletserver.TabletServer$ScanTask.get(TabletServer.java:661)
              at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1308)
              ... 15 more
      Caused by: java.lang.UnsupportedOperationException
              at org.apache.accumulo.core.iterators.WrappingIterator.deepCopy(WrappingIterator.java:45)
              at org.apache.accumulo.core.iterators.user.VersioningIterator.<init>(VersioningIterator.java:48)
              at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:44)
              at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:36)
              at org.apache.accumulo.examples.wikisearch.iterator.OptimizedQueryIterator.init(OptimizedQueryIterator.java:71)
              at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:225)
              at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:206)
              at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.createIterator(Tablet.java:2077)
              at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.iterator(Tablet.java:2019)
              at org.apache.accumulo.core.iterators.system.SourceSwitchingIterator.seek(SourceSwitchingIterator.java:163)
              at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1605)
              at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1706)
              at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler$LookupTask.run(TabletServer.java:988)
              at cloudtrace.instrument.TraceRunnable.run(TraceRunnable.java:47)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              ... 1 more
      
      

      Deleting the iterator on the wiki table allows searches to run.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 23h 57m 1 Eric Newton 10/Feb/12 13:56
        Christopher Tubbs made changes -
        Fix Version/s 1.4.0 [ 12318441 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12652521 ] patch-available, re-open possible [ 12671322 ]
        Eric Newton made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]
        Eric Newton added a comment -

        Mystery solved: follow the installation instructions and copy the latest wikisearch-query jar into accumulo/lib/ext.

        Eric Newton made changes -
        Field Original Value New Value
        Description Running a query on the wikisearch example results in this exception in the tablet server logs:

        {noformat}

        08 13:50:58,026 [thrift.TabletClientService$Processor] ERROR: Internal error processing startMultiScan
        java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1321)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.startMultiScan(TabletServer.java:1272)
                at sun.reflect.GeneratedMethodAccessor16.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at cloudtrace.instrument.thrift.TraceWrap$1.invoke(TraceWrap.java:58)
                at $Proxy2.startMultiScan(Unknown Source)
                at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor$startMultiScan.process(TabletClientService.java:2164)
                at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor.process(TabletClientService.java:2037)
                at org.apache.accumulo.server.util.TServerUtils$TimedProcessor.process(TServerUtils.java:151) at org.apache.thrift.server.TNonblockingServer$FrameBuffer.invoke(TNonblockingServer.java:631)
                at org.apache.accumulo.server.util.TServerUtils$THsHaServer$Invocation.run(TServerUtils.java:199) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
                at java.lang.Thread.run(Thread.java:662)Caused by: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
                at org.apache.accumulo.server.tabletserver.TabletServer$ScanTask.get(TabletServer.java:661)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1308)
                ... 15 more
        Caused by: java.lang.UnsupportedOperationException
                at org.apache.accumulo.core.iterators.WrappingIterator.deepCopy(WrappingIterator.java:45) at org.apache.accumulo.core.iterators.user.VersioningIterator.<init>(VersioningIterator.java:48)
                at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:44) at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:36)
                at org.apache.accumulo.examples.wikisearch.iterator.OptimizedQueryIterator.init(OptimizedQueryIterator.java:71)
                at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:225)
                at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:206)
                at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.createIterator(Tablet.java:2077)
                at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.iterator(Tablet.java:2019)
                at org.apache.accumulo.core.iterators.system.SourceSwitchingIterator.seek(SourceSwitchingIterator.java:163)
                at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1605)
                at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1706)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler$LookupTask.run(TabletServer.java:988)
                at cloudtrace.instrument.TraceRunnable.run(TraceRunnable.java:47)
                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
                ... 1 more
        {noformat}

        Deleting the iterator on the wiki table allows searches to run.
        Running a query on the wikisearch example results in this exception in the tablet server logs:

        {noformat}

        009 20:36:17,364 [thrift.TabletClientService$Processor] ERROR: Internal error processing startMultiScan
        java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1321)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.startMultiScan(TabletServer.java:1272)
                at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at cloudtrace.instrument.thrift.TraceWrap$1.invoke(TraceWrap.java:58)
                at $Proxy2.startMultiScan(Unknown Source)
                at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor$startMultiScan.process(TabletClientService.java:2164)
                at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Processor.process(TabletClientService.java:2037)
                at org.apache.accumulo.server.util.TServerUtils$TimedProcessor.process(TServerUtils.java:151)
                at org.apache.thrift.server.TNonblockingServer$FrameBuffer.invoke(TNonblockingServer.java:631)
                at org.apache.accumulo.server.util.TServerUtils$THsHaServer$Invocation.run(TServerUtils.java:199)
                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
                at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
                at java.lang.Thread.run(Thread.java:662)
        Caused by: java.util.concurrent.ExecutionException: java.lang.UnsupportedOperationException
                at org.apache.accumulo.server.tabletserver.TabletServer$ScanTask.get(TabletServer.java:661)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler.continueMultiScan(TabletServer.java:1308)
                ... 15 more
        Caused by: java.lang.UnsupportedOperationException
                at org.apache.accumulo.core.iterators.WrappingIterator.deepCopy(WrappingIterator.java:45)
                at org.apache.accumulo.core.iterators.user.VersioningIterator.<init>(VersioningIterator.java:48)
                at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:44)
                at org.apache.accumulo.core.iterators.user.VersioningIterator.deepCopy(VersioningIterator.java:36)
                at org.apache.accumulo.examples.wikisearch.iterator.OptimizedQueryIterator.init(OptimizedQueryIterator.java:71)
                at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:225)
                at org.apache.accumulo.core.iterators.IteratorUtil.loadIterators(IteratorUtil.java:206)
                at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.createIterator(Tablet.java:2077)
                at org.apache.accumulo.server.tabletserver.Tablet$ScanDataSource.iterator(Tablet.java:2019)
                at org.apache.accumulo.core.iterators.system.SourceSwitchingIterator.seek(SourceSwitchingIterator.java:163)
                at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1605)
                at org.apache.accumulo.server.tabletserver.Tablet.lookup(Tablet.java:1706)
                at org.apache.accumulo.server.tabletserver.TabletServer$ThriftClientHandler$LookupTask.run(TabletServer.java:988)
                at cloudtrace.instrument.TraceRunnable.run(TraceRunnable.java:47)
                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
                ... 1 more

        {noformat}

        Deleting the iterator on the wiki table allows searches to run.
        Eric Newton added a comment -

        Updated stacktrace to match current line numbers

        Eric Newton created issue -

          People

          • Assignee:
            Eric Newton
            Reporter:
            Eric Newton
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development