Accumulo
  1. Accumulo
  2. ACCUMULO-343

Using non-existant visibility with command-line insert should display error message.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      When I inserted a record with a visibility label that was undefined, nothing happens. These are the steps I followed:

      $ start the command line client.
      > createtable test                            
      test> insert florida george age 50 -l readable    
      test> scan
      

      Notice that there are no error messages or inserted records. Now let's define the visibility label and try again.

      test> setauths -u root -s readable
      test> insert florida george age 50 -l readable    
      test> scan
      florida george:age [readable]    50
      

      Once the visibility is defined, the record is properly inserted.

        Activity

        David Medinets created issue -
        jv made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12650037 ] patch-available, re-open possible [ 12671384 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            David Medinets
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development