Accumulo
  1. Accumulo
  2. ACCUMULO-329

tablet being unassigned/reassigned frequently

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: master
    • Labels:
    • Environment:

      doing random walk tests on a small cluster

      Description

      See the following (summary) of tablet history on a tablet server:

      19 04:38:17,053 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,061 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,200 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,225 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,359 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,369 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,504 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,512 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,686 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,694 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,843 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:17,851 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:17,996 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,005 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:18,144 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,153 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:18,311 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,320 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:18,507 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,517 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:18,674 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,686 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:18,833 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:18,842 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:19,017 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:19,027 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:19,172 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:19,182 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:19,326 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:19,336 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      19 04:38:19,477 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< opened 
      19 04:38:19,485 [tabletserver.Tablet] TABLET_HIST: !0;~;!0< closed
      

        Activity

        Eric Newton created issue -
        Eric Newton made changes -
        Field Original Value New Value
        Fix Version/s 1.4.0 [ 12318441 ]
        Affects Version/s 1.4.0 [ 12318441 ]
        Keith Turner added a comment -

        LAst night we had a successful run of random walk. I looked in the logs from this run and did not see the metadata tablets being bounced around like the master had too much mountain dew. When we saw this behavior before there were also other issues that have since been fixed. Not sure if those issues caused this in some way. We will keep looking for this issue as we test.

        Eric Newton made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Keith Turner made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Keith Turner added a comment -

        We are seing this issue with tables other than !METADATA

        Keith Turner made changes -
        Summary metadata tablet being unassigned/reassigned frequently tablet being unassigned/reassigned frequently
        Keith Turner made changes -
        Labels 14_qa_bug
        Eric Newton made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12649708 ] patch-available, re-open possible [ 12671758 ]

          People

          • Assignee:
            Eric Newton
            Reporter:
            Eric Newton
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development