Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.3, 1.7.1, 1.8.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      1.5.2 RC1, Hadoop 2.3.0, Zookeeper 3.4.5, CentOS 6, 20 node EC2

      Description

      While running RW test against 1.5.2 RC1, 10 of 17 walkers failed with a message like the following.

      16 19:35:48,820 [randomwalk.Framework] ERROR: Error during random walk
      java.lang.Exception: Error running node Concurrent.xml
              at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:285)
              at org.apache.accumulo.test.randomwalk.Framework.run(Framework.java:63)
              at org.apache.accumulo.test.randomwalk.Framework.main(Framework.java:122)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:606)
              at org.apache.accumulo.start.Main$1.run(Main.java:107)
              at java.lang.Thread.run(Thread.java:744)
      Caused by: java.lang.Exception: Error running node ct.CheckBalance
              at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:285)
              at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:254)
              ... 8 more
      Caused by: java.lang.Exception: servers are unbalanced! location 2487f8db354002f count 345 too far from average 151.86666666666667
              at org.apache.accumulo.test.randomwalk.concurrent.CheckBalance.visit(CheckBalance.java:86)
              at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:254)
      
      

        Issue Links

          Activity

          ecn Eric Newton added a comment -

          I wonder if we should just stop testing for balance in RW. It's just too chaotic.

          bhavanki Bill Havanki added a comment -

          Thanks Josh!

          FWIW, I didn't have any particular attachment to the idea of "twice the standard deviation", beyond it sounding pretty reasonable and handling the unbalanced issues at the time. So, this particular problem could either be a real thing or just not fitting into the reasonable expectation from before.

          elserj Josh Elser added a comment - - edited

          Didn't Bill Havanki try to fix this a while back? Some bell is going off..

          Found it: ACCUMULO-2488


            People

            • Assignee:
              kturner Keith Turner
              Reporter:
              kturner Keith Turner
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h

                  Development