Accumulo
  1. Accumulo
  2. ACCUMULO-2979

org.apache.accumulo.test.functional.WatchTheWatchCountIT.test failed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 1.7.0
    • Component/s: test
    • Labels:
      None

      Description

      Stacktrace
      
      java.lang.AssertionError: null
      	at org.junit.Assert.fail(Assert.java:86)
      	at org.junit.Assert.assertTrue(Assert.java:41)
      	at org.junit.Assert.assertTrue(Assert.java:52)
      	at org.apache.accumulo.test.functional.WatchTheWatchCountIT.test(WatchTheWatchCountIT.java:55)
      

        Activity

        Eric Newton added a comment -

        This test failure indicates that the number of watchers is higher than expected. It is not failing our local nightly builds. Can you log the variable "total" in your build? Also, can you describe your build environment?

        Josh Elser added a comment -

        I'm pushing a change to actually provide a message to the assert statements. Environment is a jenkins server which runs the ITs at night with one executor (it will only be running one job at a time). Because this test extends ConfigurableMacIT, it should have its own ZooKeeper process running, too. It's possible that ZK might have been getting starved and not working off watchers as you expected it to?

        Eric Newton added a comment -

        Is this still failing? Do you have the watcher count on your system?

        Josh Elser added a comment -

        My jenkins died on Friday and I didn't realize it until today, so no, I haven't seen any more failures of it yet.


          People

          • Assignee:
            Eric Newton
            Reporter:
            Josh Elser
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0h
              0h
              Logged:
              Time Spent - 10m
              10m

                Development