Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.1, 1.7.0
    • Component/s: None
    • Labels:
      None

      Description

      THRIFT-1805 caused a second regression of the issue in 0.9.1 that was fixed the first time by THRIFT-1658 in 0.9.0.

      We need to wrap RuntimeExceptions that can occur on the server side with something that doesn't kill the connection and result in the client seeing a TTransportException.

      1. ACCUMULO-2950.for160.patch
        21 kB
        Christopher Tubbs
      2. 0001-ACCUMULO-2950-Add-an-RpcWrapper-class.v2.patch
        21 kB
        Christopher Tubbs
      3. 0001-ACCUMULO-2950-Add-an-RpcWrapper-class.patch
        19 kB
        Christopher Tubbs

        Issue Links

          Activity

          Christopher Tubbs added a comment -

          If somebody can figure out how to wrap our exceptions with something that actually gets to the ProcessFunction's relevant code as a TException, I'd love to hear it. I tried a bit, and couldn't make it happen, but this code is very unfamiliar to me. Eric Newton suggested wrapping Throwable in TimedProcessor.process since it was removed from ProcessFunction in THRIFT-1805, but that gets eaten in FrameBuffer.invoke, so, I'm pretty sure they've neutered that entire block of code. I'm not sure how it is expected to get server-side exceptions to not be completely eaten and seen as network problems (TTransportException).

          Josh Elser added a comment -

          Gave a quick glance at the patch. Looks good to me at a high level!

          Josh Elser added a comment -

          Full UT/IT just finished with 100% of tests passing. Push it!

          Christopher Tubbs added a comment -

          Updated patch to include changes to proxy.

          Christopher Tubbs added a comment -

          Attaching a version of the patch which can be applied to ACCUMULO-1691 and ACCUMULO-2773 on top of 1.6.0 (rather than latest 1.6.1) ACCUMULO-2950.for160.patch


            People

            • Assignee:
              Christopher Tubbs
              Reporter:
              Christopher Tubbs
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h

                  Development