Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: test
    • Labels:
      None
    • Environment:

      master branch

      Description

      java.lang.Exception: test timed out after 240000 milliseconds
      	at java.net.SocketInputStream.socketRead0(Native Method)
      	at java.net.SocketInputStream.read(SocketInputStream.java:146)
      	at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)
      	at java.io.BufferedInputStream.read1(BufferedInputStream.java:275)
      	at java.io.BufferedInputStream.read(BufferedInputStream.java:334)
      	at org.apache.thrift.transport.TIOStreamTransport.read(TIOStreamTransport.java:127)
      	at org.apache.thrift.transport.TTransport.readAll(TTransport.java:84)
      	at org.apache.thrift.transport.TFramedTransport.readFrame(TFramedTransport.java:129)
      	at org.apache.thrift.transport.TFramedTransport.read(TFramedTransport.java:101)
      	at org.apache.thrift.transport.TTransport.readAll(TTransport.java:84)
      	at org.apache.accumulo.core.client.impl.ThriftTransportPool$CachedTTransport.readAll(ThriftTransportPool.java:270)
      	at org.apache.thrift.protocol.TCompactProtocol.readByte(TCompactProtocol.java:601)
      	at org.apache.thrift.protocol.TCompactProtocol.readMessageBegin(TCompactProtocol.java:470)
      	at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:69)
      	at org.apache.accumulo.core.master.thrift.MasterClientService$Client.recv_waitForFlush(MasterClientService.java:188)
      	at org.apache.accumulo.core.master.thrift.MasterClientService$Client.waitForFlush(MasterClientService.java:169)
      	at org.apache.accumulo.core.client.admin.TableOperationsImpl._flush(TableOperationsImpl.java:853)
      	at org.apache.accumulo.core.client.admin.TableOperationsImpl.flush(TableOperationsImpl.java:774)
      	at org.apache.accumulo.test.functional.LargeRowIT.basicTest(LargeRowIT.java:126)
      	at org.apache.accumulo.test.functional.LargeRowIT.test2(LargeRowIT.java:91)
      	at org.apache.accumulo.test.functional.LargeRowIT.run(LargeRowIT.java:74)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      

        Activity

        Eric Newton added a comment -

        Tablet server ran out of memory.

        014-03-25 07:28:23,690 [tserver.Tablet] ERROR: Unknown error during minor compaction for extent: 2;\\]jx?h@XRt8nDO%{>vT-Et-P$b.<,-4b2osta{ZE\\$u9k2T-MpdF _^<q\\M`X\\Er... TRUNCATED;F]\\;J^>ioHJ*gs[4TwSIQeN_C^]1!w@7e<wL<p.xE&TR\\g!lt6+c^0a3U7%Eo'Ji ... TRUNCATED
        java.lang.RuntimeException: java.lang.OutOfMemoryError: Java heap space
                at org.apache.accumulo.tserver.Tablet.minorCompact(Tablet.java:2058)
                at org.apache.accumulo.tserver.Tablet.access$4300(Tablet.java:170)
                at org.apache.accumulo.tserver.Tablet$MinorCompactionTask.run(Tablet.java:2127)
                at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
                at org.apache.accumulo.trace.instrument.TraceRunnable.run(TraceRunnable.java:47)
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
                at org.apache.accumulo.trace.instrument.TraceRunnable.run(TraceRunnable.java:47)
                at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
                at java.lang.Thread.run(Thread.java:701)
        Caused by: java.lang.OutOfMemoryError: Java heap space
                at java.util.Arrays.copyOf(Arrays.java:2798)
                at java.io.ByteArrayOutputStream.write(ByteArrayOutputStream.java:111)
                at java.io.DataOutputStream.write(DataOutputStream.java:107)
                at java.io.FilterOutputStream.write(FilterOutputStream.java:97)
                at org.apache.accumulo.core.data.Key.write(Key.java:624)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$IndexEntry.write(MultiLevelIndex.java:84)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$IndexBlock.add(MultiLevelIndex.java:242)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$Writer.add(MultiLevelIndex.java:440)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$Writer.flush(MultiLevelIndex.java:455)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$Writer.add(MultiLevelIndex.java:468)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$BufferedWriter.flush(MultiLevelIndex.java:388)
                at org.apache.accumulo.core.file.rfile.MultiLevelIndex$BufferedWriter.addLast(MultiLevelIndex.java:407)
                at org.apache.accumulo.core.file.rfile.RFile$Writer.closeBlock(RFile.java:400)
                at org.apache.accumulo.core.file.rfile.RFile$Writer.closeData(RFile.java:357)
                at org.apache.accumulo.core.file.rfile.RFile$Writer.close(RFile.java:325)
                at org.apache.accumulo.tserver.Compactor.call(Compactor.java:368)
                at org.apache.accumulo.tserver.MinorCompactor.call(MinorCompactor.java:96)
                at org.apache.accumulo.tserver.Tablet.minorCompact(Tablet.java:2040)
                ... 9 more
        
        ASF subversion and git services added a comment -

        Commit d77fd6fd29d2c769991b44b6f98be14b108169aa in accumulo's branch refs/heads/1.6.0-SNAPSHOT from Eric Newton
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=d77fd6f ]

        ACCUMULO-2547 run the tservers with more memory

        ASF subversion and git services added a comment -

        Commit d77fd6fd29d2c769991b44b6f98be14b108169aa in accumulo's branch refs/heads/master from Eric Newton
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=d77fd6f ]

        ACCUMULO-2547 run the tservers with more memory


          People

          • Assignee:
            Eric Newton
            Reporter:
            Eric Newton
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development