Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-2373

Daemons should be able to log if log4j.properties specifies sufficient logging

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Before this commit:
      commit 0351d0d416df51f0b10d91acdc074dced36e40d4
      Author: Josh Elser <elserj@apache.org>
      Date: Mon Feb 10 23:28:31 2014 -0500

      ACCUMULO-2334 Remove ACCUMULO_LOG_HOST in favor of pull host and port log-forwarding from zookeeper

      I was able to do logging with only log4j.properties. However, that doesn't work anymore. All my daemons have this as the last line of their logs:

      2014-02-14 14:23:38,049 INFO org.apache.accumulo.server.Accumulo: Zookeeper connected and initialized, attemping to talk to HDFS
      2014-02-14 14:23:38,067 INFO org.apache.accumulo.server.watcher.MonitorLog4jWatcher: Changing monitor log4j address to 10.20.93.170:4560
      2014-02-14 14:23:38,067 INFO org.apache.accumulo.server.watcher.MonitorLog4jWatcher: Enabled log-forwarding
      

      Note that I don't use generic_logger.xml, and this wasn't a requirement for 1.4. But now it seems there is no logging if *_logger.xml files are not present (as ACCUMULO-2349 has also reported).

        Attachments

        1. log4j.properties
          0.7 kB
          Vikram Srivastava

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                vickyuec Vikram Srivastava
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: