Accumulo
  1. Accumulo
  2. ACCUMULO-2317

remove ClientConfiguration loadDefault(String)

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: None
    • Labels:
      None

      Description

      ClientConfiguration loadDefault(String) is just calling new org.apache.commons.configuration.PropertiesConfiguration(). Users could do this themselves. Also there are many different ways to construct a PropertiesConfiguration object and there is no need for Accumulo to duplicate that.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        2h 48m 1 John Vines 03/Feb/14 23:32
        Resolved Resolved Reopened Reopened
        17h 40m 1 John Vines 04/Feb/14 17:18
        Reopened Reopened In Progress In Progress
        1h 1 John Vines 04/Feb/14 18:18
        In Progress In Progress Resolved Resolved
        48m 2 John Vines 04/Feb/14 19:01
        Bill Havanki added a comment -

        Shell works now.

        ASF subversion and git services added a comment -

        Commit ec4bc2fb274003e09fab0107f0b6d37a7df0df3a in branch refs/heads/master from Christopher Tubbs
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=ec4bc2f ]

        ACCUMULO-2317 Apply ClientOpts fix to shell also

        ASF subversion and git services added a comment -

        Commit ec4bc2fb274003e09fab0107f0b6d37a7df0df3a in branch refs/heads/1.6.0-SNAPSHOT from Christopher Tubbs
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=ec4bc2f ]

        ACCUMULO-2317 Apply ClientOpts fix to shell also

        Bill Havanki added a comment -

        I get the same error even after the latest commit. I believe the same change you made to ClientOpts needs to be made to ShellOptionsJC.

        ASF subversion and git services added a comment -

        Commit 43bf128e4393d367cdbfb5debce4de09f69bd562 in branch refs/heads/master from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=43bf128 ]

        ACCUMULO-2317 fixing shell

        John Vines made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        ASF subversion and git services added a comment -

        Commit 43bf128e4393d367cdbfb5debce4de09f69bd562 in branch refs/heads/1.6.0-SNAPSHOT from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=43bf128 ]

        ACCUMULO-2317 fixing shell

        John Vines added a comment -

        Yeah, I see what I did. Just making sure I fixed the failures.

        John Vines made changes -
        Status Reopened [ 4 ] In Progress [ 3 ]
        Bill Havanki added a comment -

        Also, I'm seeing the shell crash out on startup:

        Caused by: org.apache.commons.configuration.ConfigurationException: Cannot locate configuration source null
        ...
        	at org.apache.accumulo.core.util.shell.ShellOptionsJC.getClientConfiguration(ShellOptionsJC.java:269)
        	at org.apache.accumulo.core.util.shell.Shell.setInstance(Shell.java:414)
        

        I never pass --config-file to the shell, so the corresponding option field is null and the config cannot be built. I think with the change in ShellOptionsJC it lost the ability to load from the default search path.

        John Vines made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        John Vines added a comment -

        This seems to have broken a lot of ITs

        ASF subversion and git services added a comment -

        Commit da906f04f608b11122140a4a29bbb1f9fbde5387 in branch refs/heads/master from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=da906f0 ]

        ACCUMULO-2317 Missed these errors

        ASF subversion and git services added a comment -

        Commit da906f04f608b11122140a4a29bbb1f9fbde5387 in branch refs/heads/1.6.0-SNAPSHOT from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=da906f0 ]

        ACCUMULO-2317 Missed these errors

        ASF subversion and git services added a comment -

        Commit 1d411fbe829cd72d9c7d888c829c545e4da8cb16 in branch refs/heads/master from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=1d411fb ]

        ACCUMULO-2317 banishing loadDefault(String) and providing adequate documentation to the constructor

        John Vines made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        ASF subversion and git services added a comment -

        Commit 1d411fbe829cd72d9c7d888c829c545e4da8cb16 in branch refs/heads/1.6.0-SNAPSHOT from John Vines
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=1d411fb ]

        ACCUMULO-2317 banishing loadDefault(String) and providing adequate documentation to the constructor

        John Vines made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        John Vines made changes -
        Field Original Value New Value
        Assignee John Vines [ vines ]
        Keith Turner created issue -

          People

          • Assignee:
            John Vines
            Reporter:
            Keith Turner
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development