Accumulo
  1. Accumulo
  2. ACCUMULO-2105

[RW] Multitable.CopyTable failed from using a closed ZooKeeperInstance

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: test
    • Labels:

      Description

      27 02:03:25,324 [randomwalk.Framework] ERROR: Error during random walk
      java.lang.Exception: Error running node MultiTable.xml
      	at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:285)
      	at org.apache.accumulo.test.randomwalk.Framework.run(Framework.java:65)
      	at org.apache.accumulo.test.randomwalk.Framework.main(Framework.java:125)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.apache.accumulo.start.Main$1.run(Main.java:137)
      	at java.lang.Thread.run(Thread.java:744)
      Caused by: java.lang.Exception: Error running node mt.CopyTable
      	at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:285)
      	at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:254)
      	... 8 more
      Caused by: java.io.IOException: java.lang.RuntimeException: ZooKeeperInstance has been closed.
      	at org.apache.accumulo.core.client.mapreduce.AbstractInputFormat.getSplits(AbstractInputFormat.java:596)
      	at org.apache.hadoop.mapreduce.JobSubmitter.writeNewSplits(JobSubmitter.java:491)
      	at org.apache.hadoop.mapreduce.JobSubmitter.writeSplits(JobSubmitter.java:508)
      	at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(JobSubmitter.java:392)
      	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1268)
      	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1265)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.security.auth.Subject.doAs(Subject.java:415)
      	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1491)
      	at org.apache.hadoop.mapreduce.Job.submit(Job.java:1265)
      	at org.apache.hadoop.mapreduce.Job.waitForCompletion(Job.java:1286)
      	at org.apache.accumulo.test.randomwalk.multitable.CopyTool.run(CopyTool.java:79)
      	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
      	at org.apache.accumulo.test.randomwalk.multitable.CopyTable.visit(CopyTable.java:59)
      	at org.apache.accumulo.test.randomwalk.Module.visit(Module.java:254)
      	... 9 more
      Caused by: java.lang.RuntimeException: ZooKeeperInstance has been closed.
      	at org.apache.accumulo.core.client.ZooKeeperInstance.getInstanceID(ZooKeeperInstance.java:162)
      	at org.apache.accumulo.core.security.Credentials.toThrift(Credentials.java:62)
      	at org.apache.accumulo.core.client.impl.ThriftScanner.getBatchFromServer(ThriftScanner.java:99)
      	at org.apache.accumulo.core.metadata.MetadataLocationObtainer.lookupTablet(MetadataLocationObtainer.java:100)
      	at org.apache.accumulo.core.client.impl.TabletLocatorImpl.lookupTabletLocation(TabletLocatorImpl.java:462)
      	at org.apache.accumulo.core.client.impl.TabletLocatorImpl._locateTablet(TabletLocatorImpl.java:619)
      	at org.apache.accumulo.core.client.impl.TabletLocatorImpl.binRanges(TabletLocatorImpl.java:278)
      	at org.apache.accumulo.core.client.impl.TabletLocatorImpl.binRanges(TabletLocatorImpl.java:353)
      	at org.apache.accumulo.core.client.mapreduce.AbstractInputFormat.getSplits(AbstractInputFormat.java:582)
      	... 23 more
      

        Issue Links

          Activity

          ASF subversion and git services added a comment -

          Commit 379881e69bd7e93f11cfa13b415afe14be8634f6 in branch refs/heads/1.6.0-SNAPSHOT from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=379881e ]

          ACCUMULO-2105 cannot close instance

          ASF subversion and git services added a comment -

          Commit 379881e69bd7e93f11cfa13b415afe14be8634f6 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=379881e ]

          ACCUMULO-2105 cannot close instance

          Josh Elser added a comment -

          Eric Newton, do these changes also satisfy the comments on ACCUMULO-1923, notably MapReduceIT?

          Eric Newton added a comment -

          ACCUMULO-1923 is still open, and will probably not get closed. This experience is making me lean away from making Instance a Closable or even having the close method.

          Josh Elser added a comment -

          Final implementation aside, I was only concerned about tests that were left broken due to the changes that were applied. I suppose I can run the MapReduceIT myself with your changes.

          Thanks for looking at this, too.

          Sean Busbey added a comment -

          Eric Newton please bring up your issues in the mailing list thread on resource cleanup.


            People

            • Assignee:
              Eric Newton
              Reporter:
              Josh Elser
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development