Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: master
    • Labels:
      None

      Description

      Master is reporting in the monitor-

       
      Failed to execute Repo, tid=04a117a43b9bcadf
      	java.lang.IllegalArgumentException: Range [+r<%00; : [] 9223372036854775807 false,+inf) does not overlap [!0; : [] 9223372036854775807 false,!0<%00; : [] 9223372036854775807 false)
      		at org.apache.accumulo.core.data.Range.clip(Range.java:439)
      		at org.apache.accumulo.core.data.Range.clip(Range.java:409)
      		at org.apache.accumulo.master.tableOps.CompactionDriver.isReady(CompactRange.java:105)
      		at org.apache.accumulo.master.tableOps.CompactionDriver.isReady(CompactRange.java:65)
      		at org.apache.accumulo.master.tableOps.TraceRepo.isReady(TraceRepo.java:44)
      		at org.apache.accumulo.fate.Fate$TransactionRunner.run(Fate.java:64)
      		at org.apache.accumulo.fate.util.LoggingRunnable.run(LoggingRunnable.java:34)
      		at java.lang.Thread.run(Thread.java:701)
      06 19:14:08,0236	gc:john-P15xEMx	1	
      WARN
      org.apache.accumulo.core.client.AccumuloException: Internal error processing waitForTableOperation
      	org.apache.accumulo.core.client.AccumuloException: Internal error processing waitForTableOperation
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.doTableOperation(TableOperationsImpl.java:330)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.compact(TableOperationsImpl.java:826)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.compact(TableOperationsImpl.java:807)
      		at org.apache.accumulo.gc.SimpleGarbageCollector.run(SimpleGarbageCollector.java:474)
      		at org.apache.accumulo.gc.SimpleGarbageCollector.main(SimpleGarbageCollector.java:144)
      		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      		at java.lang.reflect.Method.invoke(Method.java:622)
      		at org.apache.accumulo.start.Main$1.run(Main.java:137)
      		at java.lang.Thread.run(Thread.java:701)
      	Caused by: org.apache.thrift.TApplicationException: Internal error processing waitForTableOperation
      		at org.apache.thrift.TApplicationException.read(TApplicationException.java:108)
      		at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:71)
      		at org.apache.accumulo.core.master.thrift.MasterClientService$Client.recv_waitForTableOperation(MasterClientService.java:610)
      		at org.apache.accumulo.core.master.thrift.MasterClientService$Client.waitForTableOperation(MasterClientService.java:595)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.waitForTableOperation(TableOperationsImpl.java:268)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.doTableOperation(TableOperationsImpl.java:310)
      		... 10 more

      Seems to correspond to this from the monitor-

      org.apache.accumulo.core.client.AccumuloException: Internal error processing waitForTableOperation
      	org.apache.accumulo.core.client.AccumuloException: Internal error processing waitForTableOperation
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.doTableOperation(TableOperationsImpl.java:330)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.compact(TableOperationsImpl.java:826)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.compact(TableOperationsImpl.java:807)
      		at org.apache.accumulo.gc.SimpleGarbageCollector.run(SimpleGarbageCollector.java:474)
      		at org.apache.accumulo.gc.SimpleGarbageCollector.main(SimpleGarbageCollector.java:144)
      		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      		at java.lang.reflect.Method.invoke(Method.java:622)
      		at org.apache.accumulo.start.Main$1.run(Main.java:137)
      		at java.lang.Thread.run(Thread.java:701)
      	Caused by: org.apache.thrift.TApplicationException: Internal error processing waitForTableOperation
      		at org.apache.thrift.TApplicationException.read(TApplicationException.java:108)
      		at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:71)
      		at org.apache.accumulo.core.master.thrift.MasterClientService$Client.recv_waitForTableOperation(MasterClientService.java:610)
      		at org.apache.accumulo.core.master.thrift.MasterClientService$Client.waitForTableOperation(MasterClientService.java:595)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.waitForTableOperation(TableOperationsImpl.java:268)
      		at org.apache.accumulo.core.client.admin.TableOperationsImpl.doTableOperation(TableOperationsImpl.java:310)
      		... 10 more

      Which is a bit strange, because it's forcing a compaction of the metadata table, but is complaining about the root tablet as part of the range?

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          5d 17h 57m 1 Keith Turner 12/Dec/13 18:16
          Christopher Tubbs made changes -
          Link This issue is related to ACCUMULO-2003 [ ACCUMULO-2003 ]
          Christopher Tubbs made changes -
          Link This issue is duplicated by ACCUMULO-2003 [ ACCUMULO-2003 ]
          ASF subversion and git services added a comment -

          Commit 02275812b6ed7cec6c4923183f2f75011f4c4f4a in branch refs/heads/master from [~keith_turner]
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=0227581 ]

          ACCUMULO-1978 fixed compaction and flush of metadata table and added test

          Keith Turner made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Keith Turner added a comment -

          I fixed this issue. I realized while working on it that compacting and flushing the root table does not work properly. But this did not work properly in 1.4 or 1.5. I am going to open a separate ticket for this issue.

          Keith Turner made changes -
          Assignee Christopher Tubbs [ ctubbsii ] Keith Turner [ kturner ]
          ASF subversion and git services added a comment -

          Commit 02275812b6ed7cec6c4923183f2f75011f4c4f4a in branch refs/heads/1.6.0-SNAPSHOT from [~keith_turner]
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=0227581 ]

          ACCUMULO-1978 fixed compaction and flush of metadata table and added test

          John Vines made changes -
          Link This issue is related to ACCUMULO-2003 [ ACCUMULO-2003 ]
          Christopher Tubbs made changes -
          Assignee Christopher Tubbs [ ctubbsii ]
          John Vines added a comment -
              if (tableId.equals(MetadataTable.ID))
                range = range.clip(new Range(RootTable.EXTENT.getMetadataEntry(), false, null, true));
          

          This is unecessary now, I'm pretty sure. And it's what's causing problems.

          John Vines made changes -
          Field Original Value New Value
          Link This issue is duplicated by ACCUMULO-1979 [ ACCUMULO-1979 ]
          John Vines created issue -

            People

            • Assignee:
              Keith Turner
              Reporter:
              John Vines
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development