Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: client, master, tserver
    • Labels:
      None

      Description

      Moving tables between namespaces is risky, because of the sudden change of inheritance from the configuration. This could introduce a lot of unexpected behavior. To avoid this, we should just prevent moving between namespaces for now. This feature can be added at a later date if it becomes highly demanded, sufficiently to warrant addressing the unique concurrency considerations.

        Activity

        Adam Fuchs added a comment -

        Christopher Tubbs Seems like moving tables between namespaces could be a nice feature. For example a table could be created in one namespace and then "published" by moving it to another namespace. What are some examples of configuration changes that can cause a problem in table migration, and can we possibly address this by documentation?

        Christopher Tubbs added a comment -

        I agree it could be a nice feature. However, it's not just documentation of behavior. It's also implementation concerns, and the introduction of bugs by swapping out the parent of a table configuration in the configuration hierarchy.

        It's not an essential part of this feature. We can always add it later.

        Besides, you can achieve the same effect, but with more well-defined behavior by cloning a table across namespaces. (It's more well-defined, because the new table will never inherit from the old configuration... only the new one, from the moment it comes online.)

        Christopher Tubbs added a comment -

        Fixed in branch.

        ASF subversion and git services added a comment -

        Commit cd6e1852b51d023718066d4e34c07dce4cf5b483 in branch refs/heads/1.6.0-SNAPSHOT from Christopher Tubbs
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=cd6e185 ]

        ACCUMULO-1907 Prevent rename across namespace

        Moving between namespaces is restricted to clone, followed by a
        deleted, which has more predictable behavior.

        ASF subversion and git services added a comment -

        Commit cd6e1852b51d023718066d4e34c07dce4cf5b483 in branch refs/heads/master from Christopher Tubbs
        [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=cd6e185 ]

        ACCUMULO-1907 Prevent rename across namespace

        Moving between namespaces is restricted to clone, followed by a
        deleted, which has more predictable behavior.


          People

          • Assignee:
            Christopher Tubbs
            Reporter:
            Christopher Tubbs
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development