Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I was running RandomWalk and ran into an issue where one of my walkers got stuck doing a merge (on table id=20). The only related error that showed up was that a file in HDFS couldn't be found (and continues to not be found, it keeps checking regularly) while trying to merge the metadata records. Here's the error:

      2013-08-14 11:54:27,246 [master.Master] ERROR: Unable merge metadata table records
      org.apache.accumulo.core.client.AccumuloException: java.io.IOException: Could not find file /20//c-00000000 in [hdfs://localhost:9000/accumulo/tables]
              at org.apache.accumulo.server.master.TabletGroupWatcher.mergeMetadataRecords(TabletGroupWatcher.java:548)
              at org.apache.accumulo.server.master.TabletGroupWatcher.updateMergeState(TabletGroupWatcher.java:368)
              at org.apache.accumulo.server.master.TabletGroupWatcher.run(TabletGroupWatcher.java:263)
      Caused by: java.io.IOException: Could not find file /20//c-00000000 in [hdfs://localhost:9000/accumulo/tables]
              at org.apache.accumulo.server.fs.VolumeManagerImpl.getFullPath(VolumeManagerImpl.java:446)
              at org.apache.accumulo.server.util.MetadataTableUtil.createDeleteMutation(MetadataTableUtil.java:501)
              at org.apache.accumulo.server.master.TabletGroupWatcher.mergeMetadataRecords(TabletGroupWatcher.java:502)
              ... 2 more
      

      And the metadata table had c-00000000 listed here:

      root@802 !METADATA> grep c-00000
      20;00b581d7479230dd srv:dir []    /c-00000000
      20< srv:dir []    /c-00000001
      

      I was testing my table namespaces code but this seemed like an unrelated issue.

        Issue Links

          Activity

          John Vines added a comment -

          Version?

          Sean Hickey added a comment -

          Sorry, 1.6, trunk/master, whatever you want to call it.

          John Vines added a comment -

          This is the same issue I saw in 1745, which got fixed by SOMETHING else.


            People

            • Assignee:
              Unassigned
              Reporter:
              Sean Hickey
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development