Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-76 Convert old tests to randomwalk framework
  3. ACCUMULO-1537

convert auto tests to integration tests, where possible for continuous integration

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.0
    • Component/s: test
    • Labels:
      None

      Description

      It would be good to run the functional tests on the build server. Now that we have MiniAccumuloCluster, most of these tests can be convert to simple java Integration Tests.

      1. accumulo-1537.fix.patch
        6 kB
        Jonathan Hsieh
      2. ipv6.patch
        1 kB
        Michael Berman
      3. macITExec.patch
        7 kB
        Michael Berman

        Issue Links

          Activity

          jira-bot ASF subversion and git services added a comment -

          Commit 1496983 from Eric Newton
          [ https://svn.apache.org/r1496983 ]

          ACCUMULO-1537 start converting python functional tests to java integration tests

          jira-bot ASF subversion and git services added a comment -

          Commit 1497085 from Eric Newton
          [ https://svn.apache.org/r1497085 ]

          ACCUMULO-1537 converting python functional tests to java integration tests

          jira-bot ASF subversion and git services added a comment -

          Commit 1498705 from Eric Newton
          [ https://svn.apache.org/r1498705 ]

          ACCUMULO-1537 converting python functional tests to java integration tests

          jira-bot ASF subversion and git services added a comment -

          Commit 1498910 from Eric Newton
          [ https://svn.apache.org/r1498910 ]

          ACCUMULO-1537 increase some timeouts, turn down the noise for running on the build servers

          jira-bot ASF subversion and git services added a comment -

          Commit 1499110 from Eric Newton
          [ https://svn.apache.org/r1499110 ]

          ACCUMULO-1537 converted many more functional tests to integration tests

          jira-bot ASF subversion and git services added a comment -

          Commit 1499414 from Eric Newton
          [ https://svn.apache.org/r1499414 ]

          ACCUMULO-1537 fixing tests and timings, migrated visibility test

          jira-bot ASF subversion and git services added a comment -

          Commit 1499562 from Eric Newton
          [ https://svn.apache.org/r1499562 ]

          ACCUMULO-1537 started the stress tests, fixed some tests, made others more reliable

          jira-bot ASF subversion and git services added a comment -

          Commit 1500063 from Christopher Tubbs
          [ https://svn.apache.org/r1500063 ]

          ACCUMULO-1537 fix compile error

          jira-bot ASF subversion and git services added a comment -

          Commit 1501497 from Eric Newton
          [ https://svn.apache.org/r1501497 ]

          ACCUMULO-1537 completed the conversion of functional tests to IT; also converted ShellServerTest to an IT

          vines John Vines added a comment -

          I don't know about anyone else, but I'm having some issues getting past these tests due to timing (I think).

          Furthermore, I'm wondering if we either want to have them run only under a certain profile, or if we should have a build profile to explicitly not include these tests due to the time involved for cases of incremental development.

          elserj Josh Elser added a comment -

          Furthermore, I'm wondering if we either want to have them run only under a certain profile, or if we should have a build profile to explicitly not include these tests due to the time involved for cases of incremental development.

          Stop running `mvn install` for SNAPSHOT builds? If you do want to build without running IntegrationTests, just add the -DskipITs when you build.

          http://maven.apache.org/surefire/maven-failsafe-plugin/examples/skipping-test.html

          ecn Eric Newton added a comment -

          The intention is to fix these issues and to make the tests run more quickly. But they are still going to take a long time: you won't want to sit through it.

          supermallen Michael Allen added a comment -

          Chiming in here from the perspective of a "I'm new to Accumulo and I'm not sure how to make it build":

          When I'm coming into a new project that's Maven-based, generally the first thing I will do after pulling source is

          mvn clean install

          If this causes a build that takes 30+ minutes, I am pretty sure this isn't a great first-time developer experience (or a not-first-time developer experience). Might I suggest putting a few choice integration tests on the main "mvn clean install" pathway and hide the rest behind a profile?

          ctubbsii Christopher Tubbs added a comment -

          Josh Elser and Michael Allen. I think you mean "mvn verify". "mvn package" should be used to build artifacts, and run through the tests. "mvn verify" should be used to run tests, build artifacts, and then do integration tests over the artifacts that have been built. "mvn install" should only be used as a precursor to deployment, or as a substitution for deployment if you need it in your local repo as a dependency for something else that you are concurrently developing.

          As Eric Newton says, the intention is to make them faster. You can skip them if you really want to go all the way through the build lifecycle, through the integration test phases, by adding the -DskipTests flag to your build command.

          For reference: http://maven.apache.org/guides/introduction/introduction-to-the-lifecycle.html#Lifecycle_Reference

          elserj Josh Elser added a comment -

          Josh Elser and .. I think you mean "mvn verify".

          Nope, meant what I wrote which was essentially the same thing you elaborated upon. For day-to-day development, install is most likely not the lifecycle a user should be invoking.

          If this causes a build that takes 30+ minutes, I am pretty sure this isn't a great first-time developer experience (or a not-first-time developer experience). Might I suggest putting a few choice integration tests on the main "mvn clean install" pathway and hide the rest behind a profile?

          I don't think we should be going against Maven conventions just to make a random first-timer have a "better" experience. In my opinion, if anything, we should go out of our way to encourage proper usage of Maven for the task at hand, which, again, is likely not `mvn install` as releases are available through maven-central (and wouldn't require a user to install the artifacts into their local repository).

          jmhsieh Jonathan Hsieh added a comment -

          I'm having compile problems on trunk currently on the Testing module.

          The root cause is that some tests in ./test/src/main depends on code in ./test/src/test (MacTest is the base class of several and lives in ./test/src/test and is depended upon by tests in ./test/src/main)

          Moving MacTest to ./test/src/main requires junit be a main dependency as opposed to a testing dependency.

          With the patch attached, the Testing Modules builds. (currently running, will report in the morning).

          jira-bot ASF subversion and git services added a comment -

          Commit 1501750 from Eric Newton
          [ https://svn.apache.org/r1501750 ]

          ACCUMULO-1537 moved integration tests to test/src/test; added more timeouts to tests

          ecn Eric Newton added a comment -

          Good catch Jonathan Hsieh, I moved the offending integration tests to test/src/test from test/src/main. Let me know if this doesn't fix it for you.

          jira-bot ASF subversion and git services added a comment -

          Commit 1501860 from Eric Newton
          [ https://svn.apache.org/r1501860 ]

          ACCUMULO-1537 improved timing/reliablity of tests

          jira-bot ASF subversion and git services added a comment -

          Commit 1501884 from Eric Newton
          [ https://svn.apache.org/r1501884 ]

          ACCUMULO-1537 fix race condition for scan timeouts

          jira-bot ASF subversion and git services added a comment -

          Commit 1501951 from John Vines
          [ https://svn.apache.org/r1501951 ]

          ACCUMULO-1537 - Adding apache header

          jira-bot ASF subversion and git services added a comment -

          Commit 1502278 from Eric Newton
          [ https://svn.apache.org/r1502278 ]

          ACCUMULO-1537 put IT output into files, make java programs identifiable using "ps"

          jira-bot ASF subversion and git services added a comment -

          Commit 1502296 from Eric Newton
          [ https://svn.apache.org/r1502296 ]

          ACCUMULO-1537 increase timeouts for build server

          jira-bot ASF subversion and git services added a comment -

          Commit 1502336 from Eric Newton
          [ https://svn.apache.org/r1502336 ]

          ACCUMULO-1537 increase timeouts, fix TableIT

          jira-bot ASF subversion and git services added a comment -

          Commit 1502343 from Eric Newton
          [ https://svn.apache.org/r1502343 ]

          ACCUMULO-1537 fix static cluster/folder in MacTest

          jira-bot ASF subversion and git services added a comment -

          Commit 1502381 from Keith Turner
          [ https://svn.apache.org/r1502381 ]

          ACCUMULO-1537 fixed NPE in MAC

          jira-bot ASF subversion and git services added a comment -

          Commit 1502639 from Eric Newton
          [ https://svn.apache.org/r1502639 ]

          ACCUMULO-1537 close batch scanners in tests

          jira-bot ASF subversion and git services added a comment -

          Commit f7e96a3e7174eb56a4eb21f7dfdf1f6a9495cc0e in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=f7e96a3 ]

          ACCUMULO-1537 make tests more stable, document in pom how to run tests in parallel

          jira-bot ASF subversion and git services added a comment -

          Commit 057b8d6cb0ccbf472067a755d76eba7ee2e3fd71 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=057b8d6 ]

          ACCUMULO-1537 convert simpler test to use a common MAC; add option to use HDFS because LocalFileSystem does not support flush/sync semantics

          jira-bot ASF subversion and git services added a comment -

          Commit 122fa39756b895ae0be0c1f3da2725c3cfb49689 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=122fa39 ]

          ACCUMULO-1537 convert simpler test to use a common MAC; add option to use HDFS because LocalFileSystem does not support flush/sync semantics

          jira-bot ASF subversion and git services added a comment -

          Commit 0793476d28c34c8ae725a9fea38af1569831813c in branch refs/heads/master from Christopher Tubbs
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=0793476 ]

          ACCUMULO-1537 Fix maven dependency problems on hadoop-test

          jira-bot ASF subversion and git services added a comment -

          Commit 4661491d0b1de8fe4d5ce1d3534de01546bfb3df in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=4661491 ]

          ACCUMULO-1537 applying Michael Berman's patches to make switching between the different MacTest classes easier

          jira-bot ASF subversion and git services added a comment -

          Commit 2709efa14baa1f7e1b32719acd61e496be9afe13 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=2709efa ]

          ACCUMULO-1537 applying Michael Berman's patches to make switching between the different MacTest classes easier, adding missing files

          jira-bot ASF subversion and git services added a comment -

          Commit 9ae8d39488a5559ca29c5b6085cfe5f2ae50d164 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=9ae8d39 ]

          ACCUMULO-1537 fix build for hadoop-2

          jira-bot ASF subversion and git services added a comment -

          Commit 040f891216154de5f7c8a87e25cefc0f816aea9c in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=040f891 ]

          ACCUMULO-1537 make the IT a bit more stable

          mberman Michael Berman added a comment -

          Two tests are left calling main() directly on a CLI tool under test. Attaching a patch to switch them to MiniAccumuloCluster.exec() so they get their environment all set up (specifically $ACCUMULO_HOME). At the moment they run fine without it, but this makes them more consistent with the rest of the IT tests, and has the benefit of allowing the tests to pass if the MAC is running with SSL turned on.

          mberman Michael Berman added a comment -

          swapping patch relative to my SSL branch for one relative to master

          jira-bot ASF subversion and git services added a comment -

          Commit ae62af822f6dfc47978ec6748f4a9b1fce15ddff in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=ae62af8 ]

          ACCUMULO-1537 commiting Michael Berman's changes to invoke main() vs exec()

          mberman Michael Berman added a comment -

          patch to help ShellServerIT pass if localhost resolves as ipv6

          jira-bot ASF subversion and git services added a comment -

          Commit 3ed8aec5ba3ce2f34ebfdc1ef624e1810c81257f in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=3ed8aec ]

          ACCUMULO-1537 committing Michael Berman's patch to run against IPV6 enabled macs

          jira-bot ASF subversion and git services added a comment -

          Commit 6591b4e94ef288a0e1219a4f3333531b752a658a in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=6591b4e ]

          ACCUMULO-1537 got IT tests to run on a slow vm

          jira-bot ASF subversion and git services added a comment -

          Commit a978b0b094a96cca4ede9d0af2cb94dcb92185fe in branch refs/heads/master from Christopher Tubbs
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=a978b0b ]

          ACCUMULO-1537 Remove warnings

          jira-bot ASF subversion and git services added a comment -

          Commit 21f93e34bce1e3e1769cab6f98d7d85ecac2fce7 in branch refs/heads/master from Eric Newton
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=21f93e3 ]

          ACCUMULO-1537 allow for fork count to be set at the cmd line

          jira-bot ASF subversion and git services added a comment -

          Commit 12dfbe47461cb12289efef20b9e22b2fce8dbc67 in branch refs/heads/master from Christopher Tubbs
          [ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=12dfbe4 ]

          ACCUMULO-1537 Check exception in test cleanup and separate compact test

          jira-bot ASF subversion and git services added a comment -

          Commit 1592854 from Keith Turner in branch 'site/trunk'
          [ https://svn.apache.org/r1592854 ]

          ACCUMULO-2396 added ACCUMULO-1537 to release notes


            People

            • Assignee:
              ecn Eric Newton
              Reporter:
              ecn Eric Newton
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development