Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-1040

Variable name inconsistency in "Reading Data" client code snippet

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.4.2
    • Fix Version/s: 1.5.0
    • Component/s: docs
    • Labels:
      None

      Description

      On the "Writing Clients" doc page, in the section "SCANNER" (at http://accumulo.apache.org/1.4/user_manual/Writing_Accumulo_Clients.html#Reading_Data), there is the following code snippet:

      for(Entry<Key,Value> entry : scan) {
          String row = e.getKey().getRow();
          Value value = e.getValue();
      }
      

      In the loop body, e should be entry.

      The same error also exists further down the page in the "BATCHSCANNER" section.

        Attachments

          Activity

            People

            • Assignee:
              kturner Keith Turner
              Reporter:
              mberman Michael Berman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: