Bug 9371 - Classloader does not load the local web apps "lib" directory before loading "shared" repository
Classloader does not load the local web apps "lib" directory before loading "...
Status: RESOLVED DUPLICATE of bug 6374
Product: Tomcat 4
Classification: Unclassified
Component: Unknown
4.0.3 Final
PC All
: P3 blocker (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-05-24 06:31 UTC by Paul Chung
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Chung 2002-05-24 06:31:17 UTC
I have tried using xalan in my web application. I have put the xalan's jar 
files in my <webapp>/web-inf/lib/ directory but tomcat couldn't find it. I 
found that those "jar" files in the <webapp>/web-inf/lib/ doesn't override 
the "xerces.jar" located in <tomcat home>/common/lib. This is in contrast with 
the documentation in "http://jakarta.apache.org/tomcat/tomcat-4.0-doc/class-
loader-howto.html"

This problem forced me to change the existing xerces.jar in "common" folder to 
the xalan version. But it causes me having another problem when installing 
another application, which uses a different version of W3C DOM APIs.
Comment 1 Remy Maucherat 2002-05-24 06:34:18 UTC

*** This bug has been marked as a duplicate of 6374 ***