Bug 8594 - Buidl fails in apr on Solaris Sparc 2.8
Buidl fails in apr on Solaris Sparc 2.8
Status: CLOSED DUPLICATE of bug 8214
Product: Apache httpd-2
Classification: Unclassified
Component: Build
2.0.35
Sun Solaris
: P3 critical (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-04-27 22:23 UTC by Drew Schatt
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Schatt 2002-04-27 22:23:42 UTC
gmake[4]: Entering directory `/home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc'
cpp -D_ASM -D__STDC__=0 /home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc/apr_atomic_sparc.s > apr_atomic_sparc.S
In file included from /home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc/apr_atomic_sparc.s:63:
/usr/include/sys/asm_linkage.h:104: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:113: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:120: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:133: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:133: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:143: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:143: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:152: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:169: `#' operator should be followed by a macro 
argument name
/usr/include/sys/asm_linkage.h:177: `#' operator should be followed by a macro 
argument name
/home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc/apr_atomic_sparc.s:113: unterminated 
character constant
gmake[4]: *** [apr_atomic_sparc.lo] Error 1
gmake[4]: Leaving directory `/home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/home/schatt/src/apache2/httpd-
2.0.35/srclib/apr/atomic/solaris_sparc'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/home/schatt/src/apache2/httpd-2.0.35/srclib/apr'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/schatt/src/apache2/httpd-2.0.35/srclib'
gmake: *** [all-recursive] Error 1


Machine is using gcc 2.95.3, Solaris 8 10/01, and the configure options 
are: ./configure --enable-so --with-mpm=worker --prefix=/usr/local/apache2.
The same configuration works fine on an identically configured Solaris x86 box, 
if that helps at all.
The LDFLAGS on the machine are set to: -L/usr/local/lib -R/usr/local/lib
Any ideas as to what to do to get it to compile?
Comment 1 Joshua Slive 2002-04-27 22:31:46 UTC
I believe that this is fixed in CVS.  In any case, check the bugs linked
to bug 8214 for more info.

*** This bug has been marked as a duplicate of 8214 ***