Bug 762 - http header appears between pages due to response.sendRedirect
http header appears between pages due to response.sendRedirect
Status: RESOLVED DUPLICATE of bug 356
Product: Tomcat 3
Classification: Unclassified
Component: Connectors
3.2.1 Final
PC All
: P1 blocker (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2001-02-28 18:09 UTC by Allen Levin
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments
two web pages appended rather than switched (4.18 KB, text/html)
2001-02-28 18:11 UTC, Allen Levin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allen Levin 2001-02-28 18:09:15 UTC
When switching between jsp's using       
response.sendRedirectresponse.encodeRedirectURL("JspBBorder1.jsp"));
the following appears between pages:

HTTP/1.1 200 OK Date: Thu, 01 Mar 2001 01:57:16 GMT Server: Apache/1.3.14 
(Win32) mod_jk Pragma: No-cache Expires: Thu, 01 Jan 1970 00:00:00 GMT Cache-
Control: private Servlet-Engine: Tomcat Web Server/3.2.1 (JSP 1.1; Servlet 2.2; 
Java 1.3.0; Windows 2000 5.0 x86; java.vendor=Sun Microsystems Inc.) Keep-
Alive: timeout=15, max=98 Connection: Keep-Alive Transfer-Encoding: chunked 
Content-Type: text/html;charset=8859_1 78c 

Pages are not switched they are appended with the above message inserted 
between them.

Using Apache 1.3.19,jakarta-tomcat-3.2.1,mod_jk.dll on Windows 2000 pro.
Comment 1 Allen Levin 2001-02-28 18:11:12 UTC
Created attachment 29 [details]
two web pages appended rather than switched
Comment 2 Yanik Cr 2001-03-01 06:59:31 UTC
The code automatically inserted by Dreamweaver UltraDev (4.0) related to user 
uthentication generates the same bug. I have carefully checked the Java code in 
the JSP page and found nothing that could instruct the response object to send 
its buffer back before the sendRedirect command is issued.
Comment 3 Ignacio J. Ortega 2001-03-11 15:35:06 UTC

*** This bug has been marked as a duplicate of 356 ***