Bug 55857 - Performance : AbstractProperty should test for emptiness to avoid Exception throwing
Performance : AbstractProperty should test for emptiness to avoid Exception t...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.6
All All
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-12-08 14:40 UTC by Philippe Mouawad
Modified: 2013-12-08 14:43 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2013-12-08 14:40:27 UTC
Profiling application I see thousands of NumberFormatException thrown during a Test using HttpSampler.

Root cause is getIntValue parsing an empty field and only testing for nullity instead of also testing for emptiness.
Comment 1 Philippe Mouawad 2013-12-08 14:41:15 UTC
This bug affects all versions of JMeter up to 2.10
Comment 2 Philippe Mouawad 2013-12-08 14:43:49 UTC
Date: Sun Dec  8 14:43:05 2013
New Revision: 1549031

URL: http://svn.apache.org/r1549031
Log:
Bug 55857 - Performance : AbstractProperty should test for emptiness to avoid Exception throwing
Bugzilla Id: 55857

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/testelement/property/AbstractProperty.java
    jmeter/trunk/xdocs/changes.xml