Bug 55610 - View Results Tree : Add an XPath Tester
View Results Tree : Add an XPath Tester
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
All All
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-09-29 12:24 UTC by Philippe Mouawad
Modified: 2013-11-23 14:34 UTC (History)
1 user (show)



Attachments
XPath Tester Screenshot (89.62 KB, image/png)
2013-11-11 21:58 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2013-09-29 12:24:44 UTC
Hello,
Using frequently JMeter, I feel this feature is missing and would be very useful as for XML responses XPath is frequently useful.
Comment 1 Philippe Mouawad 2013-11-11 21:58:05 UTC
Created attachment 31034 [details]
XPath Tester Screenshot
Comment 2 Philippe Mouawad 2013-11-11 22:00:25 UTC
Date: Mon Nov 11 21:56:26 2013
New Revision: 1540858

URL: http://svn.apache.org/r1540858
Log:
Bug 55610 - View Results Tree : Add an XPath Tester
Bugzilla Id: 55610

Added:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsXPath.java   (with props)
Modified:
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages.properties
    jmeter/trunk/src/core/org/apache/jmeter/resources/messages_fr.properties
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml


Date: Mon Nov 11 21:59:33 2013
New Revision: 1540861

URL: http://svn.apache.org/r1540861
Log:
Bug 55610 - View
Comment 3 Milamber 2013-11-18 22:09:51 UTC

This XPath tester is very very slow. On my core i5, when I select the xpath tester, I must wait more than 1 minute to display their pane (on Html page)

The first time, I believed that my computer (linux) has been crashed (stopped), and I prepared to make a hard reset!

This new tester is too slow to display the pane for the end user, I think it must be tuned / fixed.
Comment 4 Milamber 2013-11-18 22:11:08 UTC

When I try to display the Xpath tester pane (on html page), I have this message (on stderr):

[Fatal Error] :49:3: The element type "meta" must be terminated by the matching end-tag "</meta>".
Comment 5 Philippe Mouawad 2013-11-18 22:15:26 UTC
Can you show what XML you tested ? Or did you try HTML ?
Comment 6 Philippe Mouawad 2013-11-18 22:24:28 UTC
What is the size of your XML ?

It is strange, I test on this for example:
- http://projects.apache.org/feeds/rss/jmeter.xml

It is not slow at all.


Also for me, XPath is for XML. CSS/JQuery is for HTML.
The error you mention is due to formatting, I will fix it.
Comment 7 Philippe Mouawad 2013-11-18 22:26:08 UTC
Tried on HTML not able to reproduce.
What is your java version ?
Comment 8 Milamber 2013-11-19 06:22:53 UTC

Yes, If the XML (or HTML) pages are correct (without syntax errors) the xpath tester isn't slow.
Like : http://projects.apache.org/feeds/rss/jmeter.xml

But with html page with syntax errors, it's need to wait a lot of time to display the xpath tester

Example:
http://jmeter.apache.org/ or http://jmeter.apache.org/issues.html
[Fatal Error] loose.dtd:31:3: The declaration for the entity "HTML.Version" must end with '>'.

https://www.google.fr
[Fatal Error] :1:3: The markup in the document preceding the root element must be well-formed.

http://www.royalairmaroc.com/fr-fr  (more than 1 min)
[Fatal Error] :34:106: Attribute "href" was already specified for element "a".

Java JDK 7u45 64 bits on Linux Debian 7
Comment 9 Philippe Mouawad 2013-11-23 14:34:38 UTC
Date: Sat Nov 23 14:33:37 2013
New Revision: 1544809

URL: http://svn.apache.org/r1544809
Log:
https://issues.apache.org/bugzilla/show_bug.cgi?id=55610
Fix slow display issue due to XML formatting when content is not XML.
Formatting is anyway not a good idea.
Bugzilla Id: 55610

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/visualizers/RenderAsXPath.java