Bug 55432 - CSV Dataset Config loses sharing mode when switching languages
CSV Dataset Config loses sharing mode when switching languages
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.9
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-08-16 13:40 UTC by Sebb
Modified: 2013-08-19 22:10 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2013-08-16 13:40:26 UTC
As per Bug 53679 CSV Dataset Config loses sharing mode when switching languages.

This issue is for tracking fixes to CSV Data Set.
Comment 1 Sebb 2013-08-16 16:08:06 UTC
This is not as easy to fix as ConstantThroughputTimer, because the sharing Mode can be an arbitrary String value, as well as one of the 3 possible sharing modes.

The sharing modes need to be translated into the local language for display (only), but the String value is not subject to translation.
Comment 2 Sebb 2013-08-17 14:00:42 UTC
URL: http://svn.apache.org/r1514993
Log:
CSV Dataset Config loses sharing mode when switching languages
Bugzilla Id: 55432

Modified:
    jmeter/trunk/bin/testfiles/GenTest210.jmx
    jmeter/trunk/bin/testfiles/GenTest27.jmx
    jmeter/trunk/src/components/org/apache/jmeter/config/CSVDataSet.java
    jmeter/trunk/src/components/org/apache/jmeter/config/CSVDataSetBeanInfo.java
    jmeter/trunk/xdocs/changes.xml
Comment 3 Sebb 2013-08-17 16:41:09 UTC
URL: http://svn.apache.org/r1515011
Log:
CSV Dataset Config loses sharing mode when switching languages
Updated docs
Bugzilla Id: 55432

Modified:
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 4 Philippe Mouawad 2013-08-19 21:10:06 UTC
Hello,
On MacOSX, there is a regression introduced by the fix.

Scenario:
- choose edit as sharing mode
- fill in some text
- move to another test element 
- go back to CSV, data is lost


Same issue if you save.
Comment 5 Sebb 2013-08-19 22:10:15 UTC
It's not just CSV Dataset - JSR223 Preproces has the same issue.

Looks like I broke ComboStringEditor while implementing Bug 55440

I'll close this and re-open that.