Bug 55201 - ForEach controller excludes start index and includes end index (clarified documentation)
ForEach controller excludes start index and includes end index (clarified doc...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.9
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 55495 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-07-05 15:10 UTC by Artem Karpenko
Modified: 2013-08-28 17:10 UTC (History)
3 users (show)



Attachments
Simple test case (5.45 KB, text/plain)
2013-07-05 15:10 UTC, Artem Karpenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Karpenko 2013-07-05 15:10:27 UTC
Created attachment 30539 [details]
Simple test case

Despite what documentation says (http://jmeter.apache.org/usermanual/component_reference.html#ForEach_Controller) ForEach starts looping with the startIndex+1 value and ends with endIndex, i.e. output variable has value of (startIndex + 1) on the first iteration and value of (endIndex) on the last iteration.

Having taken a brief look through SVN history I've got an impression that this bug is so long-standing that could be considered "a feature" and it could be wiser to correct documentation instead of possibly breaking behavior of existing tests suites.
Comment 1 Philippe Mouawad 2013-07-05 16:10:23 UTC
Thanks for pointing this.


Date: Fri Jul  5 16:08:22 2013
New Revision: 1500053

URL: http://svn.apache.org/r1500053
Log:
Bug 55201 - ForEach controller excludes start index and includes end index (clarified documentation)
Bugzilla Id: 55201

Modified:
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 2 Philippe Mouawad 2013-07-05 20:54:18 UTC
Date: Fri Jul  5 20:42:41 2013
New Revision: 1500127

URL: http://svn.apache.org/r1500127
Log:
Bug 55201 - ForEach controller excludes start index and includes end index (clarified documentation)
Bugzilla Id: 55201

Modified:
    jmeter/trunk/xdocs/usermanual/component_reference.xml

Date: Fri Jul  5 20:52:48 2013
New Revision: 1500132

URL: http://svn.apache.org/r1500132
Log:
Bug 55201 - ForEach controller excludes start index and includes end index (clarified documentation)
Bugzilla Id: 55201

Modified:
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 3 Philippe Mouawad 2013-08-28 17:10:26 UTC
*** Bug 55495 has been marked as a duplicate of this bug. ***