Bug 55027 - Test Action regression, duration value is not recorded
Test Action regression, duration value is not recorded
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
All All
: P2 regression (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks: 55103
  Show dependency tree
 
Reported: 2013-05-29 16:25 UTC by Milamber
Modified: 2013-07-08 11:25 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milamber 2013-05-29 16:25:45 UTC
With last svn trunk, the field 'Duration' isn't record/save his value after click on another element in the tree.
(not works with Linux and jdk6|7 and Win7 and jdk7)

With 2.9, works fine.
Comment 1 Milamber 2013-05-29 16:30:09 UTC
If you insert a value in Duration field, click on Stop radio button, click outside Test action element (for example Test Plan), return to Test Action element, click on Pause radio button, then it's work...
Comment 2 Sebb 2013-05-29 16:43:57 UTC
AFAICT, this regression was caused by something external to TestAction and its GUI class, as those have not changed.

The problem seems to be that modifyTestElement is now called before the focus listener saves the new value.

This could potentially affect other GUIs.
Comment 3 Milamber 2013-05-29 18:36:59 UTC
The issue was introduce by his commit (works before, not after)

Author: pmouawad
Date: Wed Apr 17 20:16:53 2013
New Revision: 1469057

URL: http://svn.apache.org/r1469057
Log:
Bug 54834 - Improve Drag & Drop in the jmeter tree 
Bugzilla Id: 54834

Added:
    jmeter/trunk/src/core/org/apache/jmeter/gui/tree/JMeterTreeTransferHandler.java   (with props)
Removed:
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/DragNDrop.java
Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/MainFrame.java
    jmeter/trunk/src/core/org/apache/jmeter/gui/action/ActionNames.java
    jmeter/trunk/src/core/org/apache/jmeter/gui/tree/JMeterTreeListener.java
    jmeter/trunk/xdocs/changes.xml
Comment 4 Philippe Mouawad 2013-05-29 19:55:46 UTC
Date: Wed May 29 19:53:36 2013
New Revision: 1487615

URL: http://svn.apache.org/r1487615
Log:
Bug 55027 - Test Action regression, duration value are not record
Bugzilla Id: 55027

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/sampler/gui/TestActionGui.java
    jmeter/trunk/xdocs/changes.xml
Comment 5 Philippe Mouawad 2013-05-29 19:56:46 UTC
Thanks for reporting and investigating.
I cleaned up code of TestActionGui regarding usage of FocusListener which is not necessary.
Comment 6 Sebb 2013-05-29 23:06:17 UTC
I agree that the fix to TestActionGui was sensible; it would have been a sensible fix even without the bug as the extra field was unnecessary.

However why does the focus listener now get called after modifyTestElement?

That might affect other GUI elements.
And it might affect future GUI coding where a focus listener might be required.
Comment 7 Philippe Mouawad 2013-06-15 17:30:14 UTC
Closing after opening 55103 as  from Users point of view this bug is fixed.