Bug 54950 - ModuleController : Changes to referenced Module are not taken into account if changes occur after first run and referenced node is disabled
ModuleController : Changes to referenced Module are not taken into account if...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.9
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 54271 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-05-10 09:43 UTC by Wolfgang Heider
Modified: 2013-08-03 20:58 UTC (History)
3 users (show)



Attachments
Test Plan showing issue (6.51 KB, text/plain)
2013-06-30 14:05 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Heider 2013-05-10 09:43:48 UTC
The representative Test Plan (sorry, I'm not allowed to provide the original Test Plan):

- Threadgroup
 - Module Controller: Link to "Test Fragment"

- Test Fragment (disabled!)
 - SOAP/XML-RPC Request


Reproduce:

1) Store this test plan (with Test Fragment disabled!).
2) (Re-)start JMeter and load this test plan.
3) Execute the test plan.
3) Change something (e.g., Name) in the request.
-> The changes are not applied for the following test executions (until JMeter is restarted)
Comment 1 Philippe Mouawad 2013-06-30 14:00:38 UTC
Bug also happens if a TransactionController is used instead of Test Fragment.
Comment 2 Philippe Mouawad 2013-06-30 14:05:21 UTC
Created attachment 30505 [details]
Test Plan showing issue

To see bug in action
1) Start JMeter and load this test plan.
3) Execute the test plan.
3) Change something (e.g., Name) in the request.
-> The changes are not applied for the following test executions (until the Test Plan is reloaded)
Comment 3 Philippe Mouawad 2013-06-30 14:12:22 UTC
Date: Sun Jun 30 14:11:15 2013
New Revision: 1498127

URL: http://svn.apache.org/r1498127
Log:
Bug 54950 - ModuleController : Changes to referenced Module are not taken into accound if changes occur after first run and referenced node is disabled
Bugzilla Id: 54950

Modified:
    jmeter/trunk/src/components/org/apache/jmeter/control/ModuleController.java
    jmeter/trunk/xdocs/changes.xml
Comment 4 Philippe Mouawad 2013-08-03 20:58:55 UTC
*** Bug 54271 has been marked as a duplicate of this bug. ***