Bug 54538 - GUI: context menu is too big
GUI: context menu is too big
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.9
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 56338 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2013-02-07 23:37 UTC by shmulikk
Modified: 2014-04-04 21:26 UTC (History)
2 users (show)



Attachments
screenshot (191.76 KB, image/png)
2013-02-07 23:37 UTC, shmulikk
Details
Not happy menu with large screen (127.85 KB, image/png)
2013-02-09 16:33 UTC, Milamber
Details
screenshot after fix (183.11 KB, image/png)
2013-02-18 22:41 UTC, shmulikk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shmulikk 2013-02-07 23:37:20 UTC
Created attachment 29932 [details]
screenshot

Using JMeter + JMeter plugins creates too long list of listeners to be shown on my laptop screen (common 768px height).
Context menus should adapt to screen size with either a scrolling option or more than a single column.

Screenshot attached.
Comment 1 Philippe Mouawad 2013-02-09 13:27:30 UTC
Date: Sat Feb  9 13:25:36 2013
New Revision: 1444359

URL: http://svn.apache.org/r1444359
Log:
Bug 54538 - GUI: context menu is too big
Bugzilla Id: 54538

Added:
    jmeter/trunk/src/jorphan/org/apache/jorphan/gui/MenuScroller.java   (with props)
Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/util/MenuFactory.java
    jmeter/trunk/src/jorphan/org/apache/jorphan/gui/GuiUtils.java
    jmeter/trunk/xdocs/changes.xml


Date: Sat Feb  9 13:26:45 2013
New Revision: 1444361

URL: http://svn.apache.org/r1444361
Log:
Bug 54538 - GUI: context menu is too big
SVN ELO
Bugzilla Id: 54538

Modified:
    jmeter/trunk/src/jorphan/org/apache/jorphan/gui/MenuScroller.java   (props changed)
Comment 2 Milamber 2013-02-09 16:33:07 UTC
Created attachment 29934 [details]
Not happy menu with large screen
Comment 3 Philippe Mouawad 2013-02-09 17:40:59 UTC
Date: Sat Feb  9 17:38:46 2013
New Revision: 1444402

URL: http://svn.apache.org/r1444402
Log:
Bug 54538 - GUI: context menu is too big
Improve based on Screen display
Bugzilla Id: 54538

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/gui/util/MenuFactory.java
    jmeter/trunk/src/jorphan/org/apache/jorphan/gui/GuiUtils.java
Comment 4 shmulikk 2013-02-18 22:41:57 UTC
Created attachment 29964 [details]
screenshot after fix

positioning/length of the list is strange to me but I can now access all items in the context menu, so I am cool with it. Thanks Philippe!
Comment 5 Philippe Mouawad 2014-04-04 21:26:41 UTC
*** Bug 56338 has been marked as a duplicate of this bug. ***