Bug 54271 - Module Controller breaks if test plan is renamed
Module Controller breaks if test plan is renamed
Status: RESOLVED DUPLICATE of bug 54950
Product: JMeter
Classification: Unclassified
Component: Main
2.6
All All
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-12-10 06:03 UTC by Hari Krishna Dara
Modified: 2013-08-03 20:58 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hari Krishna Dara 2012-12-10 06:03:10 UTC
It seems like module controller needs to know the name of the current test plan to be able to successfully resolve the module to call, but the problem is that it doesn't get updated when the test plan is renamed, so all references suddenly become invalid.

It is very easy to reproduce this. Simply open any test plan with a module call, and rename the test plan. If you then select the module controller, it would no longer show any module to call (you may have to save and reload).
Comment 1 Philippe Mouawad 2012-12-13 21:52:08 UTC
Date: Thu Dec 13 21:51:15 2012
New Revision: 1421565

URL: http://svn.apache.org/viewvc?rev=1421565&view=rev
Log:
Bug 54271 - Module Controller breaks if test plan is renamed
Bugzilla Id: 54271

Modified:
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 2 Philippe Mouawad 2013-08-03 20:58:55 UTC
Fixed as part of 54950.

Date: Sat Aug  3 20:54:52 2013
New Revision: 1510067

URL: http://svn.apache.org/r1510067
Log:
Bug 54271 - Module Controller breaks if test plan is renamed
Bugzilla Id: 54271

Modified:
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml

*** This bug has been marked as a duplicate of bug 54950 ***