Bug 53715 - JMeter does not load WSDL
JMeter does not load WSDL
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.7
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 42717 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-08-14 10:41 UTC by carettoa
Modified: 2012-08-25 19:16 UTC (History)
2 users (show)



Attachments
My wsdl file (1.86 KB, text/xml)
2012-08-14 10:41 UTC, carettoa
Details
jmeter log file in DEBUG (224.20 KB, application/octet-stream)
2012-08-14 14:50 UTC, carettoa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description carettoa 2012-08-14 10:41:30 UTC
Created attachment 29225 [details]
My wsdl file

Dear All,
my jmeter installation (2.7 r1342410) does not load my simple wsdl, both by file (with url "file:C:\Program Files\apache-jmeter-2.7\bin\mytest\WSMyUpper.wsdl") and by http (with url "http://127.0.0.1:7001/MyLastWSProject/MyOperations?WSDL").

When i push the "Load WSDL" button, nothing appear in the "Web methods" box.

Attached you can find my wsdl file.

Thanks a lot and best regards.
   Antonio
Comment 1 carettoa 2012-08-14 10:44:07 UTC
This issue is blocking my test activities. Pleas, could you suggest me how to solve it?
Comment 2 Philippe Mouawad 2012-08-14 10:51:02 UTC
As a workaround , use soapui to generate your xml soap message from your wsdl.
Then use regular http sampler with post bofy option and past your xml.
Then add a header manager to add the required headers of your ws.

Regards

Philippe M.

Http://www.ubik-ingenierie.com

For this issue, can you put jmeter in debug and attach clean log file ?
Thanks
Comment 3 carettoa 2012-08-14 14:50:54 UTC
Created attachment 29227 [details]
jmeter log file in DEBUG

The attachment contains log file for jmeter in DEBUG.
Comment 4 carettoa 2012-08-14 14:55:22 UTC
I have just attached the jmeter.log file produced putting in DEBUG the contents of jmeter.properties, like the following:


log_level.jmeter=DEBUG
log_level.jmeter.junit=DEBUG
log_level.jmeter.control=DEBUG
log_level.jmeter.testbeans=DEBUG
log_level.jmeter.engine=DEBUG
log_level.jmeter.threads=DEBUG
log_level.jmeter.gui=WARN
log_level.jmeter.testelement=DEBUG
log_level.jmeter.util=WARN
log_level.jmeter.util.classfinder=WARN
log_level.jmeter.test=DEBUG
log_level.jmeter.protocol.http=DEBUG
# For CookieManager, AuthManager etc:
log_level.jmeter.protocol.http.control=DEBUG
log_level.jmeter.protocol.ftp=DEBUG
log_level.jmeter.protocol.jdbc=DEBUG
log_level.jmeter.protocol.java=DEBUG
log_level.jmeter.testelements.property=DEBUG
log_level.jorphan=DEBUG

Thanks a lot.
   Antonio
Comment 5 Sebb 2012-08-14 15:02:19 UTC
Note that JMeter only supports an early version of WSDL.

There don't appear to be any WSDL parsers in Java with a suitable licence.
It's a lot of work to create a parser, and it's only needed to create the test plan - it's not needed at run time.
Comment 6 Philippe Mouawad 2012-08-20 19:36:55 UTC
Issue is due to the fact that current implementation was expecting some prefixes for wsdl, soap namespaces.
Comment 7 Philippe Mouawad 2012-08-20 19:43:44 UTC
Date: Mon Aug 20 19:41:59 2012
New Revision: 1375186

URL: http://svn.apache.org/viewvc?rev=1375186&view=rev
Log:
Bug 53715 - JMeter does not load WSDL
Bugzilla Id: 53715

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/util/WSDLHelper.java
    jmeter/trunk/xdocs/changes.xml
Comment 8 Philippe Mouawad 2012-08-25 19:16:06 UTC
*** Bug 42717 has been marked as a duplicate of this bug. ***